#3 Update FAQ topic on reporting bugs

WEBSITE
closed
None
fixed
Known_bugs
2013-02-01
2000-11-05
Anonymous
No

Topic 23 of the mingw FAQ (quoted below) is outdated.

---begin---
http://www.mingw.org/mingwfaq.shtml#howwheretoreportbugs

23.How/where to report bugs

When sending in a bug report, please be sure to send a
short example of the problem. If the problem cannot be
recreated, it cannot be debugged. Also, see the list of
known problems at
http://www.nanotech.wisc.edu/~khan/software/gnu-win32/gcc.html
before reporting a problem.

You can report bugs to cygwin. See
http://gcc.gnu.org/faq.html#bugreport
for more information. You can also bring problems up on
the mingw32 mailing list.
---end---

Both links above are outdated.

I suggest replacing it with language such as this:

---begin---
23.How/where to report bugs

Please use this online form [link follows] to report bugs:
http://sourceforge.net/bugs/?func=addbug&group_id=2435

When writing a bug report, be sure to send a complete,
minimal test case that reproduces the problem. These
guidelines [link follows]
http://gcc.gnu.org/bugs.html
explain how to write an effective report. But don't
report a mingw-specific bug to gnu.org; send it to us
using the online form above.

If you are not sure whether the problem is with the gnu
tools, mingw itself, or your own code, then it is best
to send a message to the mingw mailing list [link follows]
http://www.mingw.org/lists.shtml#mingw
first. It is often a good idea to post to the mailing
list anyway, where you may receive helpful suggestions.
---end---

Discussion

    • assigned_to: nobody --> pgarceau
     
    • assigned_to: pgarceau --> pfalcon
    • status: open --> closed-fixed
     
  • Earnie Boyd
    Earnie Boyd
    2013-02-01

    • status: closed-fixed --> closed
    • resolution: --> fixed
    • category: --> Known_bugs
    • milestone: --> WEBSITE