Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#25 linker fooled by the string '-lAux'

OTHER
closed
Earnie Boyd
binutils (105)
wont-fix
Known_bugs
2013-01-21
2001-03-02
Anonymous
No

I am using the linker from the file
ld-2.10.91-20010126.zip and gcc.exe
from gcc-2.95.2-20001116.zip.

With this combination it was is possible to link with
following command:

$(CC) -o $@ $(objects) -L../Glaux -lAux -lTk -lFirst
-lopengl32 -lglu32

Test showed that is the string -lAux, which foolt the
linker. The linker
starts and never ends; the linker runs forever.

The same error give the simple command

gcc main.o -L. -lAux

It helps to rename the file libAux.a to libAuxOwl.a ot
to use the full name of the lib to prevent the error.
Examples:

gcc main.o -L. -lAuxOwl

$(CC) -o $@ $(objects) -L../Glaux -lAuxOwl -lTk -lFirst
-lopengl32 -lglu32

$(CC) -o $@ $(objects) ../Glaux/libAux.lib -L../Glaux
-lTk -lFirst -lopengl32
-lglu32

Using gcc.exe and ld.exe from Mumit's last snapshot
(Feb. 2000) '-lAux' does not fool the linker.

Discussion

  • Danny Smith
    Danny Smith
    2001-03-03

    Logged In: YES
    user_id=11494

    I've tried to duplicate this bug (renaming a lib to
    libAux.a and linking against) and could not reproduce
    problem using either CVS ld or Paul's 20000126 release of
    ld. This is on NT.

    Danny

     
    • assigned_to: nobody --> pfalcon
     
    • priority: 5 --> 2
     
    • priority: 2 --> 1
    • milestone: --> Known_bugs
    • status: open --> open-wont-fix
     
  • Logged In: YES
    user_id=11970

    O well, I finally understood what could cause this.
    'aux' is a reserved device name on dos/win32. Using it as
    filename (with any extension) is known to give problems.
    Since one of the lookup name for -lfoo which ld tries is
    foo.a, this could cause it.

     
  • Earnie Boyd
    Earnie Boyd
    2001-06-07

    • assigned_to: pfalcon --> earnie
    • status: open-wont-fix --> closed-wont-fix
     
  • Earnie Boyd
    Earnie Boyd
    2013-01-21

    • labels: ld --> binutils
    • status: closed-wont-fix --> closed
    • resolution: --> wont-fix
    • category: --> Known_bugs
    • milestone: Known_bugs --> OTHER