#2107 MinGW Installer Failure

INSTALLER
closed
Earnie Boyd
None
Bug
fixed
Unknown
False
2014-08-15
2013-10-14
Jonas
No

If I want to mark mingw32-base and mingw-developer-toolkit for installation,
I get many Popups which say:

internal package specefication error can´t get 'tarname' for non-release element <<< unknown >>>
please report this to the package maintainer
===>
libgcc-4.8.1-4-mingw32-dll-1.tar requires mingw32-libmpc-*-mingw32-dll-4.tar: unresolved dependency ......
==> other popups

After these popups the packages get marked, and I can download it, but after that I
can´t compile a c++ programm cause it says that libgmp-10.dll misses.

I added the Path Variables.

My System:
AMD FX-8120,
Windows 7 Professional,
8GB Kingston Hyper-X Ram,
NVIDIA GTX-560

Sincerly,
Caesiumhydroxid

Discussion

1 2 > >> (Page 1 of 2)
  • Keith Marshall
    Keith Marshall
    2013-10-14

    • assigned_to: Earnie Boyd
     
  • Keith Marshall
    Keith Marshall
    2013-10-14

    Please see this mailing list thread, for a discussion on the pop-ups you have observed. Unfortunately, Earnie's package specification for his latest GCC release is riddled with errors and omissions; there is one declared dependency on a non-existent libmpc release, and there appear to be several other mandatory dependencies which have not been declared.

     
  • Jonas
    Jonas
    2013-10-14

    Ok so I think there is nothing I can do except waiting for a new, fixed release.
    Thanks for your help.

     
  • Keith Marshall
    Keith Marshall
    2013-10-14

    To be more explicit, libmpc is not installed because libgcc-4.8.1-4 incorrectly declares a requirement for non-existent libmpc-*-dll-4; it should be libmpc-*-dll-2, (or perhaps libmpc-*-dll-3, but I seriously question what backwardly incompatible API change occurred between libmpc-1.0.1-1 and libmpc-1.0.1-2, that necessitated the bump from dll-2 to dll-3; that seems entirely unwarranted, and bogus to me).

    libmpfr and libgmp are not selected, because they are indirect dependencies, via libmpc; once that is correctly specified, these two should be pulled in automatically.

    gcc-core-4.8.1-4 is also lacking dependencies for binutils, mingwrt, and w32api.

    I think there is nothing I can do except waiting for a new, fixed release.

    You think wrongly! You may run the installer again, (not the setup tool), and select the latest versions of binutils, mingwrt, w32api, and libmpc yourself; mark them for installation, then apply, and your installation should then work. It's a faff that you should not have to go through, but until this defect is fixed, it's the best option open to you.

     
    Last edit: Keith Marshall 2013-10-14
  • Jonas
    Jonas
    2013-10-14

    I didn´t think of this.
    Thanks for your fast help, it works now.

    Edited

     
    Last edit: Jonas 2013-10-14
  • Keith Marshall
    Keith Marshall
    2013-10-14

    I don't know what you mean by writing "Closed", in your reply. You have a work around for the issue, but the underlying defect remains; the ticket must remain open, until that is addressed, even if you no longer have a specific interest in the outcome.

     
  • Jonas
    Jonas
    2013-10-14

    Ok, sorry didn´t know that.
    I am going to delete that from my previous post.

     
  • Earnie Boyd
    Earnie Boyd
    2013-10-14

    • status: open --> closed
    • Resolution: none --> fixed
     
  • Earnie Boyd
    Earnie Boyd
    2013-10-14

    This was caused by a careless change indicating libmpc-dll-4 instead of libmpc-dll-3. The catalogue has been updated to reflect the correct library.

     
  • Keith Marshall
    Keith Marshall
    2013-10-15

    • status: closed --> open
     
1 2 > >> (Page 1 of 2)