#2063 mingw-get:package selection does not enforce interface version matching

INSTALLER
open
Bug
none
Unknown
False
2013-09-25
2013-09-25
Keith Marshall
No

When selecting candidate packages from the catalogue, either to match a requirement specification, or a package selection named by the user, a catalogue entry with no interface (component) version specification matches a request with any specified version. This is inappropriate.

A discussion of the issues surrounding this may be found here. Formally:

no interface version == no interface version
specific interface version == same specific interface version

are the only cases which should evaluate as true. Currently:

no interface version == any specific interface version

is also evaluating as true; it should evaluate as false, just as:

specific interface version == any other specific interface version

does (correctly).

Related

Issues: #2060
Issues: #2150

Discussion