#2056 gcov version mismatch

OTHER
upstream
nobody
None
Support
none
component_package
False
2013-09-19
2013-09-19
ferus.tigris
No

I use gcov+gcovr.py for generate coverage reports on Linux.
On Windows (Windows Enterprise 7 x64) I installed MinGW (gcc version 4.8.1) and I generate binary coverage reports (files such as .gcno, .gcda), but command

gcc -fprofile-arcs -ftest-coverage -O0 ./gcov_test.c
a.exe
gcov gcov_test.c

return
gcov_test.gcno:version 408*', prefer304m'
out of memory allocating 3852114712 bytes

I looked the code, but magic with GCOV_VERSION too mistical for me.

4 Attachments

Discussion

  • Earnie Boyd
    Earnie Boyd
    2013-09-19

    • status: unread --> upstream
    • Type: Bug --> Support
    • Category: User_Error --> component_package
     
  • Earnie Boyd
    Earnie Boyd
    2013-09-19

    It's a bit "mistical [sic]" to me as well. You need to open a GCC bugs and see what those who code it say.