Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1486 GCC : Cannot find gmp-3.dll

OTHER
closed
nobody
gcc (462)
works-for-me
Unreproducible
2014-08-26
2010-10-25
Hibou57
No

Was using MinGW which was always working fine so far, when wanted to update it. Removed it, and then downloaded the last one to install it.

Unfortunately, it seems the new installer cannot install it properly, as running GCC 4.5 always ends in a complaint : “cannot find gmp-3.dll”. I could not find this gmp-3.dll anywhere, even at source-forge, and there is only a gmp-10.dll. I wanted to try a manual install, but not better.

If this GCC really requires a gmp-3.dll, then it should be provided by the installer or in the downloadable file at source-forge. Or else, may be the installer install a wrong GCC.

Is there a link to get the old MinGW which was working fine by the way ? (I removed the one I was using)

Discussion

  • Hibou57
    Hibou57
    2010-10-25

    Even more surprising now. I have tried again, with the exact same installer, the exact same selection of package to install (Ada and C), and now the behavior has changed. It does not complain anymore about a missing gmp-3.dll, and instead it is simply doing nothing at all.

    I tried “gcc test.c” where C can be either a valid C file, or an empty file or a file with any garbages you want, it does not even complains and return any error message, it simply do nothing at all and terminates.

    Unfortunately, I cannot find anymore the old MinGW which was fine.

    Is there a link where it could be possible to get it back ?

     
  • Hibou57
    Hibou57
    2010-10-25

    More feed-back : if you run this GCC from cmd.exe, then you get the “missing gmp-3.dll” error message (the first I reported) and if you run it from the other Windows console, Power Shell (there is a Power Shell for Windows XP, indeed), then you get the second report I made, GCC do nothing at all.

     
  • Hibou57
    Hibou57
    2010-10-25

    I tried a zip archive provided here :

    http://nuwen.net/mingw.html

    But this one give another error which is “gcc.exe: CreateProcess: No such file or directory”

    Why is the old version not available any more ?

     
  • Hibou57
    Hibou57
    2010-10-25

    Download gmp3-dll from this site :
    http://cs.nyu.edu/exact/core/gmp/ (as it is not provided here)
    and it is still not OK. Now it complains about a “_gmp_get_memory_functions” which could not be found (and I still can't find an archive of the old MinGW).

     
  • Hibou57
    Hibou57
    2010-10-25

    OK, I found a work around : do a copy of a libgmp-10.dll which is there and rename that copy into libgmp-3.dll and it will work nice.

     
  • Keith Marshall
    Keith Marshall
    2010-10-25

    I cannot reproduce your issue; for me, `mingw-get install c++' creates a completely functional C/C++ installation of GCC-4.5.0. There is no evidence of any dependency on gmp-3.dll, nor should there be -- gmp-10.dll is the correct version. Please provide a minimal but complete self-contained test case to demonstrate how this issue may be reproduced.

    Regarding older versions, if you still wish to use GCC-3.4.5, `mingw-get install gcc-v3-foo', (where `foo' represents any one of the standard GCC language names), will installl it for you. All older packages remain available on SF, (as their policy dictates); none have been removed. However, the old MinGW-5.x installer packages have been hidden from the standard SF browser interface, because they were attracting too many redundant enquiries of the `why don't you adapt this for GCC-4.5?' variety; that is never going to happen, and we grew tired of repeating the reasons for this.

     
  • Keith Marshall
    Keith Marshall
    2010-10-25

    • milestone: --> Unreproducible
    • status: open --> pending-works-for-me
     
  • Hibou57
    Hibou57
    2010-10-25

    Here is one. See the attached file.
    To reproduce
    * Unzip the archive
    * open a console in the bin directory
    * set your PATH environment variable to an empty string (to ensure there is no pollution)
    * type “./gcc test.c” or “.\gcc- test.c” depending on the kind of console you use.
    * this should be OK, as both libgmp-3.dll libgmp-10.dll are there.
    * now remove or rename libgmp-3.dll so that it cannot be found
    * type again the above compilation command
    * now you get an error about a missing libgmp-3.dll

    TBH : I do not understand at all what's going on here, as I've check none of the *.exe or *.dll here declares a dependencies to a libgmp-3.dll. There is just cc1.exe which indeed has a similar dependency, except it is to libgmp-10.dll.

    Note : both libgmp-10.dll and libgmp-3.dll must be present ! If you remove libgmp-10.dll, you got an error and if you remove libgmp-3.dll and leave libgmp-10.dll, you got an error as well. It need both.

    The suggestion to primarily set your PATH environment variable to an empty string ensure the test is not polluted by anything else.

    The archive contains a minimal working set.

    A note aside : can you tell Grishcka, the one who opened the report “gcc: CreateProcess: No such file or directory”, this may be a trouble with his/her PATH environment variable ? I know this message can occur if there are conflicting gcc/ld/as/etc installed on a machine. She/he should try to clear the path as I suggest here (sorry, cannot post a comment myself on this report, so I tell you here).

     
  • Hibou57
    Hibou57
    2010-10-25

    • status: pending-works-for-me --> open-works-for-me
     
  • Hibou57
    Hibou57
    2010-10-25

    Seems I cannot upload the archive here (always get an error “Expectations failed”).
    So here is a link where I uploaded it :
    http://www.les-ziboux.rasama.org/download/mingw-bug.zip

     
  • Keith Marshall
    Keith Marshall
    2010-11-01

    Providing a binary image of your defective installation doesn't represent a valid test case; all I require is your (trivial) test.c file. Thus, attempting to reproduce your issue, from an existing MSYS installation, I did the following:

    $ PS1='\n\$ '

    $ rm -rf /c/sandbox/mingw32/MinGW

    I then pointed my browser (Firefox-3.6) at http://sourceforge.net/projects/mingw/files/Automated%20MinGW%20Installer/mingw-get-inst-20101030/mingw-get-inst-20101030.exe/download and ran it, selecting c:\sandbox\mingw32\MinGW as the installation path, and C, C++ and FORTRAN as the components to be installed.

    Having successfully completed the installation, I returned to the MSYS session, where I proceeded as follows:

    $ pwd -W
    C:/MSYS/1.0/home/keith

    $ umount /mingw

    $ mount c:/sandbox/mingw32/MinGW /mingw

    $ PATH=/mingw/bin:/bin

    $ cmd //c echo `type -a gcc.exe 2>&1`
    gcc.exe is c:/sandbox/mingw32/MinGW/bin/gcc.exe

    $ cmd //c echo `type -a libgmp-3.dll 2>&1`
    sh: type: libgmp-3.dll: not found

    $ cmd //c echo `type -a libgmp-10.dll 2>&1`
    libgmp-10.dll is c:/sandbox/mingw32/MinGW/bin/libgmp-10.dll

    $ gcc --version
    gcc.exe (GCC) 4.5.0
    Copyright (C) 2010 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    $ cat test.c
    int main( void )
    {
    return 0;
    }

    $ rm -f a.exe

    $ ls a.exe
    ls: a.exe: No such file or directory

    $ gcc test.c

    $ ls a.exe
    a.exe

    Note:

    1) I have reproduced your test.c case.

    2) I have reduced $PATH to the minimum reasonably sustainable content; there is no hint of libgmp-3.dll being accessible in this path.

    3) The gcc employed (gcc-4.5.0) is that installed from our official repository, using our officially sanctioned installation method.

    4) Compilation of *your* test case is completely successful; your issue appears to be unreproducible.

    I can only suggest that you start with a completely clean installation directory, and reinstall from scratch.

     
  • Keith Marshall
    Keith Marshall
    2010-11-01

    • status: open-works-for-me --> pending-works-for-me
     
  • This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 30 days (the time period specified by
    the administrator of this Tracker).

     
    • status: pending-works-for-me --> closed-works-for-me
     
  • Earnie Boyd
    Earnie Boyd
    2013-01-21

    • labels: --> gcc
    • status: closed-works-for-me --> closed
    • resolution: --> works-for-me
    • category: --> Unreproducible
    • milestone: Unreproducible --> OTHER