Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1170 mingw32-make worked in 5.1.3, fails in 5.1.4 on Pentium-M

OTHER
closed
make (27)
out-of-date
No_User_Response
2013-01-29
2008-05-28
thomasblom
No

I use mingw32-make to build using cross-platform makefiles on win32. I have been using this successfully for some time (distribution 5.1.3)

Recently I wiped my OS (winXP), reinstalled, and pulled the latest mingw which is now 5.1.4, though mingw32-make -v in both distributions reports version 3.81.

However, the earlier version says it is built for i386, and the newer for i686. I'm running on a Dell XPS M170 Pentium-M based machine, which is i686-class if not mistaken.

Below is a transcript from executing the simplest possible makefile. The first trial is with the mingw 5.1.4 package (note Exception); the latter is from 5.1.3, and works as expected.

c:\tmp>more Makefile

clean:
del /S /Q *.obj *.o

// First example with latest 5.1.4 distro fails:
c:\tmp>mingw32-make clean
del /S /Q *.obj *.o
mingw32-make: Interrupt/Exception caught (code = 0xc0000005, addr = 0x41f97e)

// Second example with earlier 5.1.3 distro works:
c:\tmp>mingw32-make clean
del /S /Q *.obj *.o
Could Not Find c:\tmp\*.obj

The 5.1.4 version which fails on my Pentium-M based system works fine on an Intel Mac (Core Duo) running winXP.

Let me know if I can be of any assistance in fixing this.

Discussion

  • Logged In: YES
    user_id=570619
    Originator: NO

    Would you be willing to test an i386 based build of the latest make to see if it addresses the issue?

     
    • assigned_to: nobody --> ir0nh34d
     
  • thomasblom
    thomasblom
    2008-05-30

    Logged In: YES
    user_id=1367086
    Originator: YES

    Yes, be glad to.

     
  • Logged In: YES
    user_id=20264
    Originator: NO

    It seems to be related to spaces on path. Here is example how I can reproduce this problem.

    cd c:\temp\gm
    tar -xzvf mingw32-make-3.81-20080326-3.tar.gz
    mkdir "c:\temp\gm\my path"
    copy c:\utils\7z.exe "c:\temp\gm\my path"

    test.mak:
    ---
    all: test

    test:
    7z.exe --version > test
    ---

    C:\Temp\gm\bin>mingw32-make.exe -f test.mak
    7z.exe --version > test
    mingw32-make.exe: Interrupt/Exception caught (code = 0xc0000005, addr = 0x41f96e)

    When downgrading to previous release this problem goes away.

     
  • Logged In: YES
    user_id=20264
    Originator: NO

    Oh... the path setting was forgotten:
    set path="c:\temp\gm\my path"

    Do that before make.

     
  • Jean
    Jean
    2009-03-30

    Did it addressed the issue?

     
  • Earnie Boyd
    Earnie Boyd
    2012-08-03

    Thank you for your interest in the MinGW project. This post is old and I am therefore closing it, if problems still exist
    please resubmit.

    The MinGW Project Administrators.

     
  • Earnie Boyd
    Earnie Boyd
    2012-08-03

    • milestone: --> Aged_issue
    • status: open --> closed-out-of-date
     
  • Earnie Boyd
    Earnie Boyd
    2013-01-29

    • labels: --> make
    • status: closed-out-of-date --> closed
    • resolution: --> out-of-date
    • category: --> No_User_Response
    • milestone: --> OTHER