On Wed, May 30, 2012 at 1:06 PM, Baruch Burstein <bmburstein@gmail.com> wrote:

On Thu, May 24, 2012 at 4:31 PM, Earnie Boyd <earnie@users.sourceforge.net> wrote:
On Thu, May 24, 2012 at 7:46 AM, Baruch Burstein <bmburstein@gmail.com> wrote:
On the other hand it will be easier to just add a specs file to the
/path/to/lib/gcc/TARGET/VERSION/ directory with the changed values.
You can get a specs file by simply doing g++ -dumpspecs > specs.
I tried this. I went to <mingw64_dir>\lib\gcc\x86_64-w64-mingw32\4.7.0 and ran `gcc -dumpspecs > specs`. I then edited the following line in that file:

%(cpp_unique_options) %1 %{m*} %{std*&ansi&trigraphs} %{W*&pedantic*} %{w} %{f*} %{g*:%{!g0:%{g*} %{!fno-working-directory:-fworking-directory}}} %{O*} %{undef} %{save-temps*:-fpch-preprocess}


%(cpp_unique_options) %1 %{m*} %{std*&c++11&trigraphs} %{W*&pedantic*} %{w} %{f*} %{g*:%{!g0:%{g*} %{!fno-working-directory:-fworking-directory}}} %{O*} %{undef} %{save-temps*:-fpch-preprocess}

This seems to have no affect. Am I doing something wrong?

I just tried using this spec file explicitly with the -specs="<mingw64_dir>\lib\gcc\x86_64-w64-mingw32\4.7.0\specs" and it still doesn't work. What am I doing wrong?

˙uʍop-ǝpısdn sı ɹoʇıuoɯ ɹnoʎ 'sıɥʇ pɐǝɹ uɐɔ noʎ ɟı