#15 Exception raised when setting connection string

closed
None
5
2005-05-25
2005-05-24
Sean Flook
No

I am getting the following exception reported by users

************** Exception Text **************
System.TypeInitializationException: The type initializer
for "Mimer.Mpm.Data.Extensions.MpmInfo" threw an
exception. ---> System.ApplicationException: Failed to
get Type for class
Mimer.Mpm.Data.ConfigReg.MpmConfigStartup,Mimer.
Mpm.Data.ConfigReg,Version=1.2.4.1,PublicKeyToken=
ccf5603adb8282ac,Culture=neutral,Mimer.Mpm.Data.Co
nfigReg. Please check your configuration file.
at Mimer.Mpm.Data.Extensions.MpmInfo..cctor()
--- End of inner exception stack trace ---
at
Mimer.Mpm.Data.Extensions.MpmInfo.get_DataSources
()
at Mimer.Mpm.Data.MpmConnectionStringObject..ctor
(String connectionString)
at
Mimer.Mpm.Data.MpmConnection.set_ConnectionString
(String value)
at
Symphony.Settings.frmSettings.ConnectToDatabase()

This works fine for me.

I have installed the latest version (1.2.3) on the users
machines. If I open the Data Source in the admin
application and test the connection it works fine.

Discussion

  • Sean Flook
    Sean Flook
    2005-05-24

    • status: open --> closed
     
  • Sean Flook
    Sean Flook
    2005-05-24

    Logged In: YES
    user_id=684148

    This was caused by having the debug release installed on my
    PC from previous fix.

     
  • Fredrik Ĺlund
    Fredrik Ĺlund
    2005-05-25

    Logged In: YES
    user_id=897766

    It looks like you are using a configuration file for version
    1.2.4 but you are using version 1.2.3. The exception says
    that it cannot load the version 1.2.4.1 versions of the
    classes. Install version 1.2.4 on your users machines, or
    use a configuration for version 1.2.3 instead.
    Let me know if this helps.

    /Fredrik

     
  • Fredrik Ĺlund
    Fredrik Ĺlund
    2005-05-25

    • assigned_to: nobody --> fral
    • status: closed --> open
     
  • Sean Flook
    Sean Flook
    2005-05-25

    Logged In: YES
    user_id=684148

    Fredrik

    Thanks I have managed to sort this problem out by
    recompiling with the latest 1.2.3 version. I am now
    experiencing another problem.

    The following line of code:

    if (conn.DataSourceDescriptor.DbmsType ==
    MpmDbmsTypes.Oracle)

    gives me the following exception when the application is run
    stand-alone

    Object reference not set to an instance of an object.

    This works fine when running from within Visual Studio.

    I have checked that conn (MpmConnection) is not null.

    Sean

     
  • Fredrik Ĺlund
    Fredrik Ĺlund
    2005-05-25

    Logged In: YES
    user_id=897766

    It works fine for med using Mpm 1.2.4. What kind of
    DataSource is it you are using?
    I will install and try Mpm 1.2.3 as well.

     
  • Fredrik Ĺlund
    Fredrik Ĺlund
    2005-05-25

    • status: open --> closed
     
  • Fredrik Ĺlund
    Fredrik Ĺlund
    2005-05-25

    Logged In: YES
    user_id=897766

    Ok, then I am closing this issue.

    /Fredrik