MikTeX 2.7 (setup-2.7.3224.exe)

Help
2009-04-03
2012-10-17
  • Dear Gurus,

    I have been using MikTex 2.4 for some years now. Recently I decided to go for latest MikTex 2.7

    following my old 2.4 installation, I got online installation version

    D:\MikTex\local for my local repository. That goes well & good.

    I tried to install D:\MikTex\main as my actual setup directory. But when setup is about to complete I get error with initexmf.exe

    The setup log shows following lines just before termination

    D:\MiKTeX\main\miktex\bin\initexmf.exe --mkmaps --log-file=D:\MiKTeX\main\miktex\config\uninst.log --verbose:
    Parsing config file D:\MiKTeX\main\miktex\config\updmap.cfg...
    mkfntmap: Font map file dvips35.map could not be found.
    initexmf.exe: The operation failed for some reason.

    An error occurred:
    source file: C:\work3\miktex-2.7\Libraries\MiKTeX\Core\Process.cpp
    source line: 296
    message: The operation failed for some reason.
    info: D:\MiKTeX\main\miktex\bin\initexmf.exe

    Now is this a problem with exe "initexmf.exe" or with data file it is trying to process "updmap.cfg"

    "mkfntmap: Font map file dvips35.map could not be found."

    I have removed all files from previous installation. If there is any work around to this problem... please

     
    • I did find a work around to installing MikTex 2.7, not very much to my liking.

      Story :

      After trying everything that I could without actually breaking my notebook with temper, I decided
      to use this solution as last resort.

      I logged into Windows XP "Safe mode" (ya F8 & all) with "Administrator" i.e. the default
      system Administrator that Windows XP provides. The regular account that I use on windows
      also has administrator rights, as it is the only account I have & I use.

      So with "Safe Mode" & "Administrator" MikTeX 2.7 is installed without a noise or hitch. Be sure you
      install it for "All Users" & not just "Only : Administrator" option.

      I was very happy about the apparent success. Both "Refresh FNDB" & "Update Formats" also worked & guess what I had Languages for first time in "Miktex Options". So I went ahead with setting TeXnicentre etc.

      Very jubilant , I restarted my windows, logged in normal mode to my usual account. Started TeXnicetre. Tried to compile my sample latex file & this is what I get

      This is pdftex, version 3.141592 - 1.40.4 (MikTeX 2.7)
      Running pdftex...
      ! I can't read TEX.POOL.
      makefmt: pdftex failed on pdfetex.ini.
      initexmf.EXE: The operation failed for some reason.
      I can't find default format file.

      Congratulations !! MikTex is still not able to find its default settings. All right never mind, I should check Settings-->MikTeX Options. "Update Formats" naturally does not work as usual. Again languages go missing from "Language" tab.

      Conclusions :

      1) I might have understood MikTex 2.7 installation guide wrongly but system root account means
      "The Root" or "The Administrator" and not some user account created with administrator rights
      is beyond my imagination.

      2) Although it is claimed that it should work in parallel with older version, I have never tried it. But
      it is possible that my account is still dirty with older installation, so dirty that MikTex 2.7 cannot
      find its own POOL.

      3) What is TEX.POOL? what could be possible reasons that pdftex cannot read it?

      Can someone please please direct me to its workings. So far I have managed
      to install MikTeX 2.7, which I consider big progress although it is quite useless yet.

      PS: I do not want to use Administrator account with Safe mode for my day to day work.

       
    • After racking my brains for a while, I found that something was indeed
      dirty with path on my regular account.

      I forgot my old Environment variables. I had made them , year (or maybe 2)
      back , for what reason I do not remember now. But D:\MikTex\miktex\bin was
      part of my "PATH" variable , also I had some other environment variables like

      "MIKTEX_HOME" = D:\MikTeX
      "MIKTEX_BIN" = %MIKTEX_HOME%\miktex\bin
      "PATH" = %PATH%;....;%MIKTEX_BIN%

      Probably .ini files of MikTex 2.7 uses such internal variable
      settings & also path, environment variables getting higher
      preference were messing up with them, that is my assumption.
      Hence, pointing is wrong place.

      Once , I got rid of MIKTEX_HOME & MIKTEX_BIN , MikTex 2.7 now
      seems to be back on track.

      Using Administrator account , in that case makes sense, in-fact
      any other account (with admin rights)other than my regular
      account should have worked because MIKTEX_HOME & MIKTEX_BIN
      were on my "User Variables" and not system wide.

      Thank you, Ulrike Fischer for pointing out possible checks.

      • Patrix
       
    • U_Fischer
      U_Fischer
      2009-04-03

      At first: when installing miktex it is not necessary to remove an old version. You can install a new miktex without problems parallel to the old one in a new folder. You should only remove the path to the old binaries from the path variable.

      Check if you have the file dvips35.map (it should be in
      \fonts\map\dvips\tetex\dvips35.map). If yes: update the fndb (in the miktex ->settings).

      If not check in the package manager if miktex-misc is installed and check if your version contains the map (right click in the package manager on miktex-misc and then chose properties). If necessary reinstall the package.

      Then try again
      initexmf --mkmaps (or updmap)

      Ulrike Fischer

       
    • Thanx for reply Ulrike. I badly need MikTex up & running next week, before I start punching in my thesis.

      1) The file dvips35.map is in required location

      2) Since Miktex is aborting the installation, I don't have
      Miktex->settings (which I hope meant from start-menu). But
      I did find .exe in \miktex\bin\mo.exe.
      Anyway it has "REFRESH FNDB" button on front tab.

      3) mpm_mfc.exe , which I am very sure is Package Manager shows
      miktex-misc package, it has missing map ... but suggested or
      expected path is texmf\fonts\map\dvips\tetex.

      4) Anyway since everything was seemingly in place I went
      ahead with,
      initexmf --mkmaps

      The error is not resolved.

      a) Now mo.exe has another task button right under "Refresh
      FNDB" , it is "Update Formats". It gives error message

      Creating the pdfetex format file...
      Running pdftex...
      ! I can't read TEX.POOL.
      makefmt: pdftex failed on pdfetex.ini.
      initexmf.EXE: The operation failed for some reason.

      Does that imply pdftex is broken , because of incomplete
      installation or something more irksome?

      b) Does the difference in actual path where file dvips35.map
      appears & path shown by package miktex-misc, suggest a
      problem?

      • Patrix
       
    • U_Fischer
      U_Fischer
      2009-04-05

      If you really don't have a start menu, something did go wrong during installation.
      It sounds as if miktex can find the texmf-trees. What do you get if you run

      initexmf --report

      ?

      (Probably the best is to reinstall. Use the basic-installer, it's smaller. You can always install more package later.)

      Ulrike Fischer

       
    • Thank you, Ulrike.

      I do not mind opening up some .c files & pinpoint the problem. I really doubt if same problem exists with 2.8 version as well , I hope not. As after bit of googling for solution, a similar problem existed with 2.6 as well. Do you think it is something going wrong with installation at system level or some inherit problem with packaging dependencies? Since, I have not touched Ubuntu after it's last LT release and unresolved ATI driver problem , I had to abandon Ubuntu. I do not really know if MikTeX 2.7 works well with Linux systems. I have ever used MikTex with Windows XP.

      Anyway, Screen dump of initexmf --report

      MiKTeX: 2.7
      SystemAdmin: yes
      PowerUser: no
      SharedSetup: yes
      BinDir: D:\MiKTeX\main\miktex\bin

      OS: Microsoft Windows XP Home Edition Service Pack 3 (build 2600)
      Root0: C:\Documents and Settings\Pratish\Application Data\MiKTeX\2.7
      Root1: C:\Documents and Settings\Pratish\Local Settings\Application Data\MiKTeX\2.7
      Root2: C:\Documents and Settings\All Users\Application Data\MiKTeX\2.7
      Root3: D:\MiKTeX\main
      Install: D:\MiKTeX\main

      UserData: C:\Documents and Settings\Pratish\Local Settings\Application Data\MiKTeX\2.7
      UserConfig: C:\Documents and Settings\Pratish\Application Data\MiKTeX\2.7
      CommonData: C:\Documents and Settings\All Users\Application Data\MiKTeX\2.7
      CommonConfig: C:\Documents and Settings\All Users\Application Data\MiKTeX\2.7

      fndb0: C:\Documents and Settings\Pratish\Local Settings\Application Data\MiKTeX\2.7\miktex\config\ca33c31221b1f005456e69d7ffdbf665.fndb
      fndb1: C:\Documents and Settings\Pratish\Local Settings\Application Data\MiKTeX\2.7\miktex\config\5c0696e8549be82d16f19d7023833802.fndb
      fndb2: C:\Documents and Settings\All Users\Application Data\MiKTeX\2.7\miktex\config\432dc75d83112b0d90d51efff48eddc7.fndb
      fndb3: C:\Documents and Settings\All Users\Application Data\MiKTeX\2.7\miktex\config\446c443b2c1ec20b649c753230ef3b14.fndb
      fndbmpm: C:\Documents and Settings\All Users\Application Data\MiKTeX\2.7\miktex\config\5c9c2effd97adbeacc8bf220bf73149c.fndb

      Ya, Basic will be good idea to start resolving. Is there anyway by which I can make sure that problem causing packages are not listed up for installation with Basic? some kind of customization , that installs only important stuff that I need like pdftex, apacite, bibtex & does not worry too much about
      the vast cornucopia of fonts

      • Patrix
       
    • Hello,

      I also had a try with Basic Setup but no good, problem remains as it is. Nothing on Start Menu or Add / Remove Programs either.

      • Patrix