Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

CJK/Package update issues in 2.8, 2.9

Help
2012-01-02
2012-10-17
  • I had 2.8 installed on my Windows 7 system for quite a while with no problems,
    then the other day when I typeset an old document (which worked on my system
    before), MiKTeX decided it needed to download a package it couldn't find
    (although it was there). It said it downloaded it, extracted the files (which
    it did), and then said again the package wasn't available and needed to be
    downloaded again... repeat indefinitely.

    Before I dive deeper into figuring this out, does that behavior sound familiar
    enough to anyone?

    I did think that maybe Windows ate something in MiKTeX during a Windows update
    or something odd like that, so I completely de-installed 2.8 and installed 2.9
    fresh, but while that worked for this problem, it created a new one because
    apparently the CJK font support in 2.9 is incomplete (I'll file that as a
    separate topic).

    So going back to a fresh download of 2.8, it exhibits the same (original)
    problem--it constantly thinks a bunch of packages are missing and keeps
    downloading them.

     
  • U_Fischer
    U_Fischer
    2012-01-04

    Sometimes when packages are rearranged MikTeX can get confused. Often it helps
    to synchronize the repository database (in the package manager) (in user and
    admin mode) and update the FNDBs. In a small number of cases it can been
    necessary to deinstall and reinstall the package which makes the trouble.

    Ulrike Fischer