problem with different output/aux directory

Help
Erik
2012-05-15
2012-10-17
  • Erik
    Erik
    2012-05-15

    Hello all,

    I'm totally new here, have searched this forum and the bug tracker but could
    not find entries that match my issue.

    I have several large LaTeX docs to maintain and recently decided to change
    some directory structures to keep various parts of the documents better
    separated from each other.

    What I had in mind is a folder with all .tex files and in that folder two
    subfolders, one called "Build" and the other called "Tmp".
    The created pdf should end up in Build and the other files (aux, idx, log,
    etc.) should end up in Tmp.

    I use MikTex 2.9: MiKTeX-pdfTeX 2.9.4225 (1.40.12) (MiKTeX 2.9) on a Windows
    XP SP3 system

    When I compile my document, I use the following command :

    texify  --pdf  --run-viewer --tex-option=--output-directory="Build" --tex-option=--aux-directory="Tmp" main.tex
    

    This creates my pdf, in the folder Build and places all other files in Tmp, as
    intended.

    However, I run into three problems, which seem to indicate that MikTex cannot
    deal with different output and aux folders:

    1) the viewer (activated by --run-viewer) cannot find the pdf, apparently it
    does not look in the folder "Build" but in the root folder for this document.
    The error I get in the log file:

    texify.exe: Windows API error 2: Het systeem kan het opgegeven bestand niet vinden.
    

    (The system cannot find the specified file)

    2) texify only runs once, so table of contents and references are not always
    OK. Before I changed the output folders and everything was dumped in the
    "document root", texify would run more than once when required and table of
    contents and references were all OK.

    This can be "solved" by running texify again, but why do I need to do that
    myself now, while it used to do that automatically?

    3) the index is not created. An .idx file is created in "Tmp", but the list
    does not appear in my pdf.

    I have not found a work around for this yet, ran texify multiple times after
    each other, to no avail.

    My question(s):

    Have I overlooked something that causes this to fail or is this a known issue?

    Any help is highly appreciated.

    Erik