Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Savetrees noe compatible with 2.9?

Help
Brint
2012-02-02
2012-10-17
  • Brint
    Brint
    2012-02-02

    MikTex is crashing for me on scripts that contain \usepackage{savetrees}. This
    does not happen under 2.8, which uses an older version of savetrees. Right
    now, I just want to know if anyone else has experienced this problem. If I
    hear nothing, I will post a small script.

     
  • U_Fischer
    U_Fischer
    2012-02-03

    This is the wrong group for this sort of question. Quite probably it has
    nothing to do with miktex directly. Ask e.g. in comp.text.tex, texhax or
    tex.stackexchange. If there is a bug in savetrees you should notify the author
    of the package.

    Ulrike Fischer

     
  • Brint
    Brint
    2012-02-07

    Perhaps my question should have been more complete: Under MikTeX 2.8, a 15
    page script that includes figures and equations compiles nicely with no
    errors. It uses the savetrees package. Under MikTeX 2.9, the same script
    crashes at the end of an inserted equation. By experimenting, I found that
    removing the inclusion of savetrees permits the script to compile without
    error under MikTeX 2.9.

    When the only variable is the version of MikTeX being used, it is reasonable
    to inquire as to whether MiKTeX compatibility with existing packages may be
    the problem and whether another user found the same challenge and either filed
    a bug report or found a workaround.

    Suggesting that "Quite probably" it had nothing to do with MikTeX doesn't seem
    reasonable, in view of the fact that the only variable that changed was the
    version of MikTeX.

    So I respectfully re-submit my question and hope for someone to come forth
    with a suggested solution.

    Thanks.

     
  • U_Fischer
    U_Fischer
    2012-02-10

    Sorry but the the miktex version is not an "only variable". The differences
    between a miktex 2.8 and miktex 2.9 installation can be huge, and large parts
    are not under control of the miktex maintainer (like e.g. package versions).
    You didn't offer yet any proof that the error is connected directly to the
    core binaries of miktex. You didn't sent a minimal example and no log-files.
    You actually even didn't describe exactly the error you get. "crashing" is
    rather vage. So I still find it highly probable that your error is not
    connected to the core of miktex.

    Beside this: As you can see this group has not much trafic. In other groups
    chances to find someone who can help you are much better. And: A minimal
    example that load savetrees worked fine for me.

    Ulrike Fischer