Package install fails - what to check?

  • John Beattie
    John Beattie

    Today I installed the SIunits package via the package manager gui. However,
    the latex run generates an error saying that it cannot find package
    siunits.sty. This file is certainly present, under
    C:\bin\miktex2.9\tex\latex\siunits. It is mentioned in

    Hence "I cannot find" == "I cannot find siunits.sty in the places I am

    I have updated the FNDB from the gui and from the command line, in both user
    and admin modes.

    Incidentally, where is the fndb? Is it the packages.ini file? If not, can the
    fndb be interrogated?

    Moving on, I updated my miktex installation, no change to the problem.

    Also, I tried another package, with the same result.

    On the other hand, last week my installation was missing the layouts package
    but that got installed automatically.

    Summarising, I guess that there is something wrong with my miktex installation
    but I cannot see how to make progress with investigating the problem.

    All suggestions gratefully received,
    John Beattie

  • U_Fischer

    If you have on-the-fly installation enable and miktex can't find a known
    package it should try to install it on-the-fly. So my first suspicion is that
    you had some typo in your document. If you don't think that this is the source
    of your problem: show a complete, small example that demonstrates your problem
    and the log-file.

    Ulrike Fischer

  • John Beattie
    John Beattie

    Fixed. It was a typo as you suggested.