xparse error (even after update)

Anonymous
2012-02-06
2012-10-17

  • Anonymous
    2012-02-06

    Hi, I'm using miktex 2.9. I get the error

    LaTeX Warning: You have requested, on input line 53, version
    `2012/01/19' of package expl3,
    but only version
    `2011/11/19 v2966 L3 Experimental code bundle wrapper'
    is available.
    ! Package xparse Error: Support package l3kernel too old..
    See the xparse package documentation for explanation.
    Type H <return> for immediate help.
    ...
    l.64 }
    Please install an up to date\nobreakspace {}version of l3kernel using your TeX
    package manager or from CTAN.\\ \\ Loading xparse will abort!
    

    I read that it is related to the l3kernel, and several pages say that it will
    be fixed after installing such package. Then I did, but the error is still
    there. I install l3kernel and l3packages. I check for the expl3 to uninstall
    it, but is not present in the system.

    Any suggestions on how to remove the error for the xparse package?

     
  • U_Fischer
    U_Fischer
    2012-02-06

    No problem here. All packages are up to date and I can use xparse without
    error.

    Probably you installed one of the packages in user mode. In this case you must
    also update them in user mode. Local (user) versions will always be found
    first.

    Ulrike Fischer

     

  • Anonymous
    2012-02-06

    Thanks, I didn't know that. I thought that the admin overwrites the local.
    When cleaning the local version it works.