#2312 Lua script from package "pfarrei" not properly executed, probably due to outdated library

fixed
2014-04-03
2014-03-16
Speravir
No

Although both MiKTeX 2.9 and TeX Live 2013 seem to have included the same LuaTeX version, the module loading in MiKTeX does not work (or perhaps only work in the old way). Was there perhaps a library file not properly updated?

Compare this behaviour in MiKTeX and TeX Live:

MiKTeX, script a5toa4.tlu (designed as wrapper script to pfarrei.tlu) does not work …

C:\LaTeX\MiKTeX\scripts\pfarrei>texlua -v
This is LuaTeX, Version beta-0.76.0-2013062820  (MiKTeX 2.9) (rev 4627)
[...]
C:\LaTeX\MiKTeX\scripts\pfarrei>texlua a5toa4.tlu -V
a5toa4.tlu:34: module 'pfarrei.pfarrei' not found:
        no field package.preload['pfarrei.pfarrei']
        [kpse lua searcher] file not found: 'pfarrei.pfarrei'
        [kpse C searcher] file not found: 'pfarrei.pfarrei'
        no file 'C:\LaTeX\MiKTeX\miktex\bin\pfarrei.dll'
        no file 'C:\LaTeX\MiKTeX\miktex\bin\loadall.dll'
        no file '.\pfarrei.dll'

But in TeX Live it works as designed …

C:\LaTeX\texlive\texmf-dist\scripts\pfarrei>texlua -v
This is LuaTeX, Version beta-0.76.0 (TeX Live 2013/W32TeX) (rev 4627)
[...]
C:\LaTeX\texlive\texmf-dist\scripts\pfarrei>texlua a5toa4.tlu -V
a5toa4.tlu r36

Copyright (c) 2013 Markus Kohm.
License: lppl 1.3c or later. See <http: www.latex-project.org="" lppl.txt="">.

Discussion

    • status: open --> fixed
     
  • Thank you for the report! This has been fixed now.