Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Eclipse 3.2 only works on 1st Project?

Help
2007-02-26
2013-04-24
  • Mark Ricard
    Mark Ricard
    2007-02-26

    Weird behavior.  I enabled metrics on all of my projects.  On the first project I tried, all the metrics worked beautifully.

    However, clicking on different projects yields the default "you need to do [this].." in the metrics view.

    If I click back in the original project, all is fine again.   I have "metrics" checked in each project and did a clean on everything and still see the problem.

    Anyone?

     
    • Tom
      Tom
      2007-07-31

      I have a similar problem, although I'm using Eclipse 3.3.

      I've installed the plugin through the update manager. For the first project I tried, it worked fine. Then when I enabled metrics for a second project, and rebuild it, it won't come up with the metrics. The Metrics view still displays the "you need to do..." page.

      After that the metrics for the first project also don't show up anymore!

      Unfortunately, there doesn't seem to be a lot of activity on this project, although I think it's a very useful tool.

      Anyone got it working with Eclipse 3.3?

       
    • Steve Hall
      Steve Hall
      2007-08-06

      This tool is impressive! An excellent tool to use to quickly evaluate code quality.

      I got Metrics 1.3.6 installed in just a few minutes and it seems to work fine and consistently.

      This is my Eclipse info:
      Eclipse SDK
      Version: 3.2.1
      Build id: M20060921-0945

      I downloaded the Zip for Metrics.  Unzipped the download into a folder.  Did an install through Help > Software Updates > Find and Install.  Pointed at the folder that contains the unzipped files.

      Allowed the installation to shutdown and restart Eclipse when I was prompted to.

      I right clicked each of the projects I want Metrics on, selected properties and on the Metrics property, I checked Enable Metrics.  I can profile several projects.  Uncheck Enable Metrics on the preferences panel, close the view, and can reopen the view by choosing Window > Show View > Metrics View. 

      When I get the you need to do [this]...  I followed the prompts for each project and it works.  I am working in the Package Explorer within Eclipse.

      If you are having trouble try disabling the Metrics eclipse plugin and then enabling through the Eclipse help menu.

      Good luck.