Multiple point clouds in PTX file not opened

Help
Peter
2011-04-24
2013-01-06
  • Peter
    Peter
    2011-04-24

    I have some large point cloud files in PTX format. (200Mb+) They each contain
    multiple embedded point clouds.

    When I open them with Rapidform Explorer it opens and displays all of the
    clouds. When I open with meshlab it seems to only open the first of them. I do
    not know what separates one cloud from another.

    Here are the first few lines of the file for what it is worth. It seems to be
    X, Y, Z, intensity, R, G, B.

    780
    1948
    27.427405 61.703506 -2.602057
    -0.930129 0.367233 0
    -0.367233 -0.930129 0
    0 0 1
    -0.930129 0.367233 0 0
    -0.367233 -0.930129 0 0
    0 0 1 0
    27.427405 61.703506 -2.602057 1
    -0.856857 1.926376 -2.107925 0.478309 79 78 45
    -0.857925 1.928787 -2.109177 0.480751 82 80 50
    -0.858658 1.930496 -2.109634 0.480629 91 88 66
    -0.859634 1.932693 -2.110611 0.477577 93 93 69
    -0.860641 1.935013 -2.111771 0.480873 91 89 69
    -0.860764 1.935318 -2.110611 0.487587 91 89 69
    0 0 0 0.500000 0 0 0
    0 0 0 0.500000 0 0 0
    -0.862228 1.938614 -2.110062 0.481788 102 104 76
    -0.861801 1.937668 -2.107590 0.487587 101 105 74
    -0.861435 1.936844 -2.105240 0.482582 101 105 74
    -0.862320 1.938858 -2.106094 0.484108 76 79 54
    -0.864761 1.944443 -2.110641 0.486793 58 60 42
    -0.863449 1.941422 -2.106003 0.480995 59 61 43
    0 0 0 0.500000 0 0 0
    0 0 0 0.500000 0 0 0

     
  • Arie
    Arie
    2011-06-16

    Hi pmolsen,
    I've experienced the same problem when importing a .ptx file containing
    multiple pointclouds into meshlab (1.3. 64bit).
    You got to look at the import-settings: Index of Range Map to be Imported
    Here u can specify which one of the single scans inside the .ptx file should
    be imported (count starts at zero).
    I haven't found a way to import multiple scans at once (I tried 0-15,
    0,1,2,3,4...,0;1;2;3;4 etc.) but it works if you import the ptx-file several
    times (equal the amount of single scans in the file) incremently changing the
    Index of Range Map (starting at 0, then 1, 2 and so on). Hope that will help
    you.

    If anyone knows how to import all scans at once, please drop a line here.
    Greetings from Berlin,
    Scrible

     
  • creaturemaker
    creaturemaker
    2013-01-05

    I have attempted this with no success. I've indexed the rangemaps and it continues to import the first ptx. Any solutions to this?

     
  • Finnaithe
    Finnaithe
    2013-01-06

    I use the same method as Arie. Change the Index of Range Map in the import dialog. If you want all the points in the same point cloud after import you can flatten the imported layers.