I want to add that the screen is NOT only black as I told you a few hours ago, it's black and there's (barely visible in dark grey) the output of console.
Changing to 16bit color depth results in a violet font.
In any case it's a total lock-up.

Does anyone know what could be wrong here?
Regards



On Sun, May 18, 2008 at 5:21 PM, Simon Prückl <pruexxx@gmail.com> wrote:
Ok, I fixed that problem, the file radeon_dri.so should have been in /usr/lib/xorg/modules/dri/radeon_dri.so .
So I'm able to start the sample_server, but the only thing I get is a black screen.

I cannot change to other framebuffer consoles, my ssh-session gets stuck, the only thing i can do is to reboot.

When starting via SSH i get this output:
[root@server miniglx]# ./sample_server && ./miniglx
[miniglx] probed chipset 0x4e48
got MMIOAddress 0xb7e45000 offset 134217728
shared virtual width is 1024
[drm] added 8192 byte SAREA at 0xf89cc000
[drm] mapped SAREA 0xf89cc000 to 0xb7e43000, size 8192
[drm] framebuffer handle = 0xe8000000
[drm] register handle = 0xfe9f0000
[gart] AGP enabled at 1x
[gart] 8192 kB allocated with handle 0x00000001
[gart] ring handle = 0xf8000000
[gart] ring read ptr handle = 0xf8101000
[gart] vertex/indirect buffers handle = 0xf8102000
[gart] AGP texture map handle = 0xf8302000
Using 8 MB AGP aperture
Using 1 MB for the ring buffer
Using 2 MB for vertex/indirect buffers
Using 1 MB for AGP textures
Will use back buffer at offset 0x400000
Will use depth buffer at offset 0x700000
Will use 120832 kb for textures at offset 0xa00000
[drm] Added 32 65536 byte vertex/indirect buffers
[drm] dma control initialized, using IRQ 16
[drm] Initialized kernel gart heap manager, 5111808
color tiling disabled
page flipping disabled
[miniglx] Setting mode: visible 1024x768 virtual 1024x768x32
[miniglx] Readback mode: visible 1024x768 virtual 1024x768x32
RADEONEngineRestore

When starting at the PC itself i get a black screen.

I don't know what's wrong, maybe i'll play with the settings a little bit, but if anyone has experienced something like that, please help...

Regards


On Sun, May 18, 2008 at 3:50 PM, Simon Prückl <pruexxx@gmail.com> wrote:
Hoi,

I finally managed to compile mesa with linux-solo configuration after a few weeks of trial-and-error.
Now whenever i try to start the sample_server I get this error:

[root@server miniglx]# ./sample_server &
[miniglx] probed chipset 0x4e48
got MMIOAddress 0xb7df4000 offset 134217728
Unable to open radeon_dri.so: radeon_dri.so: cannot open shared object file: No such file or directory
InitDriver failed
Error: __miniglx_StartServer failed
[1] 3325
[1]+  Exit 1                  ./sample_server

I am using Arch Linux with 2.6.25 kernel and modifications regarding the file drm_drv.c
Video Card is ATI Radeon 9800, modules radeon, radeofb, agpgart are loaded.

I have absolutly no idea why he refuses to find radeon_dri.so, the file exists in
/usr/X11R6/lib/modules/dri/radeon_dri.so
and
/usr/lib/dri/radeon_dri.so

(and of course in /root/Mesa-7.0.3/lib/radeon_dri.so and /root/Mesa-7.0.3/src/mesa/drivers/dri/radeon/radeon_dri.so)

If it should be somewhere else - please tell me.

If there's any other reason why it refuses to work, please tell me. I've absolutly no idea what could be wrong, I need your help.

Regards,
Simon Prückl



--
Simon Prückl - Prüxxx - Krift 43 - 4550 Kremsmünster



--
Simon Prückl - Prüxxx - Krift 43 - 4550 Kremsmünster