Hi Brian;

I was testing mesa demo programs on my Fedora 11 system. "shadowtex" program gave me these "errors"

Using GL_ARB_depth_texture
and GL_ARB_shadow
and GL_ARB_fragment_program
and GL_ARB_shadow_ambient
Using GL_EXT_framebuffer_object
Keys:
  a = toggle animation
  i = show depth texture image
  m = show depth texture mapping
  d = show fragment distance from light source
  n = show normal, shadowed image
  f = toggle nearest/bilinear texture filtering
  b/B = decrease/increase shadow map Z bias
  p = toggle use of packed depth/stencil
  M = cycle through fragment program modes
  v = toggle vertex program modes
  cursor keys = rotate scene
  <shift> + cursor keys = rotate light source
  o = cycle through comparison modes
*********************************WARN_ONCE*********************************
File r300_render.c function r300Fallback line 432
Software fallback:r300->radeon.Fallback
***************************************************************************
CS section size missmatch start at (r300_cmdbuf.c,emit_cb_offset,254) 16 vs 7
CS section end at (r300_cmdbuf.c,emit_cb_offset,264)
Mesa 7.5-devel implementation error: unexpected texture format in setup_hardware_state
Please report at bugzilla.freedesktop.org
CS section size missmatch start at (r300_cmdbuf.c,emit_cb_offset,254) 16 vs 7
CS section end at (r300_cmdbuf.c,emit_cb_offset,264)
Mesa 7.5-devel implementation error: unexpected texture format in setup_hardware_state
Please report at bugzilla.freedesktop.org
Mesa 7.5-devel implementation error: unexpected texture format in setup_hardware_state
Please report at bugzilla.freedesktop.org
Mesa 7.5-devel implementation error: unexpected texture format in setup_hardware_state
Please report at bugzilla.freedesktop.org
CS section size missmatch start at (r300_cmdbuf.c,emit_cb_offset,254) 16 vs 7
CS section end at (r300_cmdbuf.c,emit_cb_offset,264)
Mesa 7.5-devel implementation error: unexpected texture format in setup_hardware_state
Please report at bugzilla.freedesktop.org
CS section size missmatch start at (r300_cmdbuf.c,emit_cb_offset,254) 16 vs 7
CS section end at (r300_cmdbuf.c,emit_cb_offset,264)
Mesa 7.5-devel implementation error: unexpected texture format in setup_hardware_state
Please report at bugzilla.freedesktop.org
Mesa 7.5-devel implementation error: unexpected texture format in setup_hardware_state
------------------------------------------------------------------------------------------------------------------

I have  a ATI X1950Pro card. Hence it might be a R500 driver issue. Is this a real bug for me to report?