Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#465 Salary: Set salary no reversible

Development
closed
Dylan Myers
None
Fixed
2014-12-03
2014-02-04
Pheonix Rising
No

If you use Set Salary for whatever reason (freed prisoners, dependents, etc) you must continue to manually set that persons salary (unless there is a way to reset the salary that I haven't found yet).

In most cases with freed prisoners as they will stay at 0 until you change the rank from prisoner to none or higher (usually).

Discussion

  • Dylan Myers
    Dylan Myers
    2014-02-09

    Fixed in [r1746]

     

    Related

    Commit: [r1746]

  • Dylan Myers
    Dylan Myers
    2014-02-09

    • assigned_to: Dylan Myers
    • Resolution: None --> Fixed
     
  • Dylan Myers
    Dylan Myers
    2014-02-09

    • Milestone: Undetermined --> Development
     
  • Taharqa
    Taharqa
    2014-04-26

    • Status: open --> closed
     
  • Pheonix Rising
    Pheonix Rising
    2014-07-24

    I just discovered this was not actually fixed. I believe this section of code is preventing the reset:

    if (salary < 0) {
    return;
    }

    should it not be < -1 instead?

    If you enter -1 in the dialog it saves the change as 0

     
  • Dylan Myers
    Dylan Myers
    2014-07-24

    Umm... who said putting -1 in is correct? You don't remove it by setting it to anything. There is a separate menu entry for removing it.

     
  • Pheonix Rising
    Pheonix Rising
    2014-07-25

    Your dialog box did. I only see one option for the salary, and that is Set Salary. Nothing else above or below it and nothing replaces it when using a custom salary amount. I didn't catch this before as I had edited all salary references in the campaign file to -1 by hand.

    It is really minor though so I can post a patch that you can get to when you more time for trivial bugs such as this one.

     
    Attachments
  • Dylan Myers
    Dylan Myers
    2014-07-25

    That's odd... I distinctly remember doing a separate menu entry... I must have changed my mind for some reason. Probably because that context menu is getting quite large.

     
  • Dylan Myers
    Dylan Myers
    2014-07-25

    • status: closed --> open
     
  • Dylan Myers
    Dylan Myers
    2014-07-25

    I've implemented the correction to the fix in [r1927] and reset this as open so it'll be re-closed as fixed for the next release. Sorry about that.

     

    Related

    Commit: [r1927]

  • Pheonix Rising
    Pheonix Rising
    2014-07-25

    It happens, done it myself before.

     
  • Pheonix Rising
    Pheonix Rising
    2014-07-27

    Tested, works as intended :)

     
  • Taharqa
    Taharqa
    2014-12-03

    • Status: open --> closed