Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#682 MeGUI rev. 2184 not detecting Avisynth 2.6 alpha on x64 plat

General
closed-fixed
nobody
None
5
2013-02-10
2012-10-05
Daniel Klíma
No

Last revision 2184 no longer detects Avisynth 2.6 alpha 3 on Windows 7 x64 and Windows 8 x64 (x86 might be affected too). According to Process Monitor MeGUI sees avisynth.dll in system directory, but reports Avisynth as missing.

Looking at diff of code in VideoUtil.cs it looks like blocks x86 and x64 might be switched. (x86 specific contains code for x64)

Discussion

  • Zathor
    Zathor
    2012-10-05

    Thanks for the report,

    As I can see everything is fine. Your AviSynth build is detected properly:
    --[Information] [5.10.2012 16:34:31] AviSynth: 2.6.0.2 (25.5.2011 10:10:44)

    But those two files are missing and that is the reason MeGUI would like to download them:
    --[Error] [5.10.2012 16:34:32] Component not found: C:\Program Files (x86)\MeGUI\tools\avisynth\avisynth.dll
    --[Error] [5.10.2012 16:34:32] Component not found: C:\Program Files (x86)\MeGUI\tools\avisynth\directshowsource.dll

    Simply let the installer download those files and everything is fine.

     
  • Zathor
    Zathor
    2012-10-05

    • status: open --> pending
     
  • Daniel Klíma
    Daniel Klíma
    2012-10-05

    Looks like it works. (I see that there was rename in updater.)

    So far no futher problems observed. (At least attributable to this change)

     
  • Daniel Klíma
    Daniel Klíma
    2012-10-05

    Added: Looks like I didn't get notification of change of status. (And forgot to refresh)

    Sorry for noise.

     
  • Zathor
    Zathor
    2013-02-10

    • status: pending --> closed-fixed
    • milestone: --> General