APE (Monkey's Audio) транскоди...

Kirill
2011-09-25
2013-05-30
  • Kirill
    Kirill
    2011-09-25

    Здравствуйте. Имеется Debian squeeze, установлены mediatomb (0.12.0~svn2018-6.1) и ffmpeg (4:0.5.4-1). Не получается настроить транскодирование файлов APE.
    В секцию <extension-mimetype> добавил:

     <map from="ape" to="audio/x-monkeys-audio"/>
    

    В секцию <mimetype-contenttype> добавил:

    <treat mimetype="audio/x-monkeys-audio" as="pcm"/>
    

    Далее:

    <transcoding enabled="yes">
    <mimetype-profile-mappings>
    <transcode mimetype="audio/x-monkeys-audio" using="2pcm"/>
    ...
        <profiles>
        <profile name="2pcm" enabled="yes" type="external" >
             <mimetype>audio/L16</mimetype>
             <first-resource>yes</first-resource>
             <accept-url>yes</accept-url>
             <sample-frequency>44100</sample-frequency>
             <audio-channels>2</audio-channels>
             <hide-original-resource>yes</hide-original-resource>
             <agent command="/usr/bin/ffmpeg" arguments="-i %in -ac 2 -ar 44100 -y -f s16be %out"/>
             <buffer size="1048576" chunk-size="4096" fill-size="1024"/>
        </profile>
    ....
    

    Телевизор Philips 42PFL7606H файлы *.ape видит, но не проигрывает , пишет что "файл не поддерживается:невыполнимо". А проигрыватель Windows Media вообще эти файлы не видит. Пожалуйста, помогите настроить транскодирование, буду очень благодарен за помощь.

     
  • Kirill
    Kirill
    2011-09-26

    Все, разобрался. Вот рабочая конфигурация для проигрывания файлов Ape (Monkey's Audio). При транскодировании используется пакет ffmpeg, при этом "ape" транскодируется в "wav". Может кому пригодится :-)
    Итак, в секцию <extension-mimetype> я добавил:

    <map from="ape" to="audio/x-monkeys-audio"/>
    

    В секцию <mimetype-contenttype> ничего добавлять не нужно
    В секцию <transcoding>:

    <transcoding enabled="yes">
    <transcode mimetype="audio/x-monkeys-audio" using="2pcm"/>
    ...
    <profiles>
        <profile name="2pcm" enabled="yes" type="external" >
             <mimetype>audio/L16</mimetype>
             <first-resource>yes</first-resource>
             <accept-url>yes</accept-url>
             <sample-frequency>44100</sample-frequency>
             <audio-channels>2</audio-channels>
             <hide-original-resource>yes</hide-original-resource>
             <agent command="/usr/bin/ffmpeg" arguments="-i %in -y -f wav %out"/>
             <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
        </profile>
    ...
    </profile>
    

    Не уверен, что необходимы строки:

    <sample-frequency>44100</sample-frequency>
               <audio-channels>2</audio-channels>
    

    Но в результате проведенных манипуляций, проигрываются "обезьянки" на ура. Осталось разобраться, как заставить кушать *.cue