проблемы с mediatomb + Samsung ...

agent-0007
2010-11-12
2013-10-24
1 2 3 > >> (Page 1 of 3)
  • agent-0007
    agent-0007
    2010-11-12

    Телик видит только списки директорий, а фаилов внутри нет(
    В лог пишется странное сообщение:

    tail /var/log/mediatomb.log
    2010-11-12 00:16:16 ERROR: ActionRequest::update(): response is nil, code -115
    2010-11-12 00:16:18 ERROR: ActionRequest::update(): response is nil, code -115
    2010-11-12 00:16:18 ERROR: ActionRequest::update(): response is nil, code -115

    Посмотрел в официальной документации mediatomb
    http://mediatomb.cc/doxygen/upnp_8h.html

    UPNP_E_INVALID_ACTION

    { UPNP_E_INVALID_ACTION} signifies that the SOAP action message is invalid. This can be because the DOM document passed to the function was malformed or the action message is not correct for the given action.

    Видел еще такую же проблему обсуждали на Японском языке, но по япоцки читать к сожалению не умею(((

    Кто сталкивался - помогите плиз)

     
  • Jin
    Jin
    2010-11-20

    Народ про Самсунги вроде пишет, что нужна специальная конфигурация, пару раз выкладывалось на форуме. Не знаю поможет или нет, но вроде писали, что Самсунг сам по себе с этой конфигурацией работает. Ну а в целом мало что скажу, телик что то непонятное шлет, оттуда и ошибка…

     
  • agent-0007
    agent-0007
    2010-11-22

    Ошибку победил. Оказалось что в лог mediatomb пишется непонятная ошибка.
    Да для самсунга нужны специфические хедеры.
    В моем случае дело оказалось в секции mime type я подправи и все стало ок.

     
  • Freeg
    Freeg
    2010-12-26

    Уважаемый Агент 007, не подскажите ли как решить проблему: у меня Samsung UE40B7000WWXRU, на роутере ASUS WL-500W установил такое дело: http://wl500g.info/showthread.php?t=21889 . В линуксе вообще никакой, т.к. пользую только первые пару дней. Но по ftp к роутеру подключился и торрент клиент и довнлоанд менеджер вроде работают. А вот сервер DNLA нет. При попытке с телевизора воспроизвести файл, вываливается ошибка "формат файла не поддерживается" Причем это файлы в разных форматах. Что я делаю не так или что нужно исправить в Media Tomb и где в нем, вообще как в его настройки попасть?

     
  • agent-0007
    agent-0007
    2010-12-27

    Вам необходимо поправить фаил настройки mediatomb. Там неправильные mime у фаилов указаны.
    Подробнее как я ковырялся читайте здесь http://agent-0007.livejournal.com/94102.html

     
  • To ftcom
    Добрый день, у меня такая же проблема как у вас. Телевизор такойже.
    Не могли бы вы выложить рабочую версию config'а или выслать ее мне на почту, Заранее спасибо

     
  • Victor Vas
    Victor Vas
    2011-01-25

    А у меня телевизор mediatomb не видит. Телек 32С550, mediatomb 0.11.

    В конфиге есть параметр protocolInfo extend="yes".
    Так вот, судя по коду медиатомба это параметр должен регулировать отправку тега X_DLNA на плеер, исходя из чего плеер понимает что видит DLNA-устройство и, соотвественнно, отображает его в списке. У меня при установке этого параметра (protocolInfo extend="yes") ничего не меняется - плеер не видит mediatomb.

    Я сравнивал с самсунговским PC_ShareManager и Twonky 6.30 - так они отдают X_DLNA на плеер.

    Вопрос к разработчикам?

    Виктор.

     
  • EvgeshaH
    EvgeshaH
    2011-01-25

    victorvas

    Аналогичная проблема. WMP сервер видит, телевизор (40С630) - не видит.
    Mediatomb стоит на WD MyBook World Edition 2.
    Twonky 5.1.9 прекрасно работает (но оно не умеет передавать mkv)

    <protocolInfo extend="yes"/> прописан, а также, то, что советуют для самсунгов:

        <custom-http-headers>
          <add header="transferMode.dlna.org: Streaming"/>
          <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000"/>
        </custom-http-headers>
    
     
  • Victor Vas
    Victor Vas
    2011-01-26

    Интересно, тут бывают девелоперы?

     
  • agent-0007
    agent-0007
    2011-01-26

    На самом деле медиатомб нормальная штука, просто надо настроить нормально. Его в первую очередь должен видеть комп с виндой. Компы должны обязательно находиться в одной подсети. Разработчики думаю здесь не бывают, а сидят и пишут платный код для железок NAS

     
  • Victor Vas
    Victor Vas
    2011-01-26

    Похоже, что компиляция Mediatomb для WD была произведена с выключенным EXTEND_PROTOCOLINFO ключом.
    Кто может перекомпилировать?

     
  • Jin
    Jin
    2011-01-26

    Интересная теория :) На самом деле на МТ нам удалось заработать один раз за всю историю, когда нам дали заказ написать inotify autoscan, и все.

    После того как я купил УАЗик 1976го года выпуска разработка МТ практически остановилась и на форумы я так часто тоже уже не заглядываю, просто времени нет. Днем работа, а все свободное время на выходных уходит на ковыряние в УАЗике.. так что уж простите :)

    Где то раз в месяц стараюсь заглянуть на форум и ответить на все сообщения, но опять же, не всегда успеваю. Гляну в этот раздел на выходных, сейчас в командировке тоже не успеваю…

     
  • Victor Vas
    Victor Vas
    2011-01-26

    А он EXTEND_PROTOCOLINFO в параметрах запуска может предаваться?

     
  • Victor Vas
    Victor Vas
    2011-01-26

    В коде config_manager.cc есть праметр extend - это он?

     
  • Victor Vas
    Victor Vas
    2011-01-26

    Медиатомб - единственный мне известный с кастомизацией айтемов и возможностью добавить внешние стримы.
    Архитектору респект!!!

     
  • agent-0007
    agent-0007
    2011-01-26

    Прикольно что разработчик объявился) По поводу зароботка на МТ я бы посоветовал вам написать письма в самсунг, лж итд. Они заинтересуются данной разработкой. Мы в свое время на работе под LG телики делали виджеты, нормально платили) Проект то очень позитивный) Геморойно настраивать и мало инфы на русском. респект ребята!

     
  • Victor Vas
    Victor Vas
    2011-01-26

    Да, в вэб-морду бы натройки добавить…

     
  • Victor Vas
    Victor Vas
    2011-01-26

    Был бы продукт правильный - инфа сама появится. :-)

     
  • Victor Vas
    Victor Vas
    2011-01-26

    agent-0007,

    а что он (медиатомб) выдает на запрос http://mediatomp_ip:mediatomb_port/description.xml ?
    Можешь выложить?

     
  • agent-0007
    agent-0007
    2011-01-28

    victorvas , я не пробовал) Сегодня домой вернусь попробую, отпишусь о результате

     
  • agent-0007
    agent-0007
    2011-01-30

    victorvas, вот что он отдает:

    <?xml version="1.0"?>
    <root xmlns="urn:schemas-upnp-org:device-1-0">
    <specVersion>
    <major>1</major>
    <minor>0</minor>
    </specVersion>
    <device>
    <deviceType>urn:schemas-upnp-org:device:MediaServer:1</deviceType>
    <presentationURL>http://192.168.0.180:49152/</presentationURL>
    <friendlyName>MediaTomb</friendlyName>
    <manufacturer>(C) 2005-2008 Gena Batyan &lt;bgeradz@mediatomb.cc&gt;, Sergey Bostandzhyan &lt;jin@mediatomb.cc&gt;, Leonhard Wimmer &lt;leo@mediatomb.cc&gt;</manufacturer>

    <manufacturerURL>redsonic.com</manufacturerURL>
    <modelDescription>Free UPnP AV MediaServer, GNU GPL</modelDescription>
    <modelName>MediaTomb</modelName>
    <modelNumber>105</modelNumber>
    <serialNumber>1</serialNumber>
    <UDN>uuid:7b63d4ce-de6d-4cb9-b4f3-4c9898d2dbc6</UDN>
    <iconList>
    <icon>
    <mimetype>image/png</mimetype>
    <width>120</width>

    <height>120</height>
    <depth>24</depth>
    <url>/icons/mt-icon120.png</url>
    </icon>
    <icon>
    <mimetype>image/x-ms-bmp</mimetype>
    <width>120</width>
    <height>120</height>
    <depth>24</depth>
    <url>/icons/mt-icon120.bmp</url>

    </icon>
    <icon>
    <mimetype>image/jpeg</mimetype>
    <width>120</width>
    <height>120</height>
    <depth>24</depth>
    <url>/icons/mt-icon120.jpg</url>
    </icon>
    <icon>
    <mimetype>image/png</mimetype>
    <width>48</width>

    <height>48</height>
    <depth>24</depth>
    <url>/icons/mt-icon48.png</url>
    </icon>
    <icon>
    <mimetype>image/x-ms-bmp</mimetype>
    <width>48</width>
    <height>48</height>
    <depth>24</depth>
    <url>/icons/mt-icon48.bmp</url>

    </icon>
    <icon>
    <mimetype>image/jpeg</mimetype>
    <width>48</width>
    <height>48</height>
    <depth>24</depth>
    <url>/icons/mt-icon48.jpg</url>
    </icon>
    <icon>
    <mimetype>image/png</mimetype>
    <width>32</width>

    <height>32</height>
    <depth>8</depth>
    <url>/icons/mt-icon32.png</url>
    </icon>
    <icon>
    <mimetype>image/x-ms-bmp</mimetype>
    <width>32</width>
    <height>32</height>
    <depth>8</depth>
    <url>/icons/mt-icon32.bmp</url>

    </icon>
    <icon>
    <mimetype>image/jpeg</mimetype>
    <width>32</width>
    <height>32</height>
    <depth>8</depth>
    <url>/icons/mt-icon32.jpg</url>
    </icon>
    </iconList>
    <serviceList>
    <service>
    <serviceType>urn:schemas-upnp-org:service:ConnectionManager:1</serviceType>

    <serviceId>urn:schemas-upnp-org:serviceId:ConnectionManager</serviceId>
    <SCPDURL>cm.xml</SCPDURL>
    <controlURL>/upnp/control/cm</controlURL>
    <eventSubURL>/upnp/event/cm</eventSubURL>
    </service>
    <service>
    <serviceType>urn:schemas-upnp-org:service:ContentDirectory:1</serviceType>
    <serviceId>urn:schemas-upnp-org:serviceId:ContentDirectory</serviceId>
    <SCPDURL>cds.xml</SCPDURL>
    <controlURL>/upnp/control/cds</controlURL>

    <eventSubURL>/upnp/event/cds</eventSubURL>
    </service>
    </serviceList>
    </device>
    <URLBase>http://192.168.0.180:49152/</URLBase>
    </root>

     
  • agent-0007
    agent-0007
    2011-01-30

    ВОТ конфиг
    <?xml version="1.0" encoding="UTF-8"?>
    <config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd">
      <server>
        <ui enabled="yes">
          <accounts enabled="no" session-timeout="30">
            <account user="xxx" password="xxx"/>
          </accounts>
        </ui>
       
        <name>MediaTomb</name>
        <udn>uuid:7b63d4ce-de6d-4cb9-b4f3-4c9898d2dbc6</udn>
        <home>/var/lib/mediatomb</home>
        <webroot>/usr/share/mediatomb/web</webroot>
       
        <storage>
          <sqlite3 enabled="no">
            <database-file>sqlite3.db</database-file>
          </sqlite3>
         
          <mysql enabled="yes">
            <host>localhost</host>
            <username>mediatomb</username>
            <database>mediatombMysqlDSisd_s223</database>
          </mysql>
        </storage>
       
        <protocolInfo extend="yes"/><!- For PS3 support change to "yes" ->

        <custom-http-headers>
            <add header="X-User-Agent: redsonic"/>
    <!- Samsung needs it ->
            <add header="transferMode.dlna.org: Streaming"/>
            <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01500000000000000000000000000000"/>
        </custom-http-headers>

        <manufacturerURL>redsonic.com</manufacturerURL>
        <modelNumber>105</modelNumber>
       
        <extended-runtime-options>
         <ffmpegthumbnailer enabled="yes">
      <thumbnail-size>128</thumbnail-size>
              <seek-percentage>5</seek-percentage>
              <filmstrip-overlay>yes</filmstrip-overlay>
              <workaround-bugs>yes</workaround-bugs>
        </ffmpegthumbnailer>
       
        <mark-played-items enabled="yes" suppress-cds-updates="yes">
          <string mode="prepend">*</string>
        </mark-played-items>
        </extended-runtime-options> 
      </server>

      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <common-script>/usr/share/mediatomb/js/common.js</common-script>
          <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
          <virtual-layout type="builtin">
            <import-script>/usr/share/mediatomb/js/import.js</import-script>
          </virtual-layout>
        </scripting>
       
        <mappings>
          <extension-mimetype ignore-unknown="no">
            <map from="mp3" to="audio/mpeg"/>
            <map from="ogg" to="application/ogg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="m3u" to="audio/x-mpegurl"/>
            <map from="pls" to="audio/x-scpls"/>
            <map from="flv" to="video/x-flv"/>
            <map from="avi" to="video/divx"/>
            <map from="avi" to="video/avi"/>
          </extension-mimetype>
         
          <mimetype-upnpclass>
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
          </mimetype-upnpclass>
         
          <mimetype-contenttype>
            <treat mimetype="audio/mpeg" as="mp3"/>
            <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
    <treat mimetype="video/x-mkv" as="mp4"/>
    <treat mimetype="video/x-msvideo" as="asf"/>
          </mimetype-contenttype>
        </mappings>
      </import>
     
      <transcoding enabled="no">
      <mimetype-profile-mappings>
      <transcode mimetype="application/ogg"   using="audio-generic"/>
      <transcode mimetype="audio/x-flac"      using="audio-generic"/>
      <transcode mimetype="video/x-ms-asf"    using="video-generic"/>
      <transcode mimetype="video/x-flv"       using="video-generic"/>
      <transcode mimetype="video/x-matroska"  using="video-generic"/>
      <transcode mimetype="video/x-quicktime" using="video-generic"/>
      <transcode mimetype="video/quicktime"   using="video-generic"/>
      </mimetype-profile-mappings>
      <profiles>
     
      <profile name="audio-generic" enabled="yes" type="external" >
      <mimetype>audio/L16</mimetype>
      <first-resource>yes</first-resource>
      <accept-url>yes</accept-url>
      <sample-frequency>44100</sample-frequency>
      <audio-channels>2</audio-channels>
      <hide-original-resource>yes</hide-original-resource>
      <agent command="ffmpeg" arguments="-ac 2 -ar 44100 -y -i %in -f s16be %out"/>
      <buffer size="1048576" chunk-size="4096" fill-size="1024"/>
      </profile>
     
      <profile name="video-generic" enabled="yes" type="external">
      <avi-fourcc-list mode="ignore">
      <fourcc>DX50</fourcc>
      <fourcc>DM4V</fourcc>
      <fourcc>M4S2</fourcc>
      </avi-fourcc-list>
      <mimetype>video/mpeg</mimetype>
      <accept-url>yes</accept-url>
      <first-resource>yes</first-resource>
      <hide-original-resource>yes</hide-original-resource>
      <accept-ogg-theora>yes</accept-ogg-theora>
      <agent command="/usr/local/bin/mediatomb-video-generic" arguments="%in %out"/>
      <buffer size="1048576" chunk-size="26214" fill-size="52428"/>
      </profile>
     
      </profiles>
      </transcoding>

    </config>

     
  • agent-0007
    agent-0007
    2011-01-30

    С данным конфигом работает все по просмотру гуд, перемотка и пауза работают корректно ;)

    Пока не удалось победить ffmpeg tumbanaller
    В Debian Lenny этого пакета нет, а ставить тестинг версию неохота.
    Пытался от туда оторвать данный пакет, но ничего не получилось.Кто-нить заморачивался на эту тему?

     

  • Anonymous
    2011-02-20

    Ребят, прошу помощи. Имею телек самсунг 7 серии. Прогу настроил, вот конфиг

    <?xml version="1.0" encoding="UTF-8"?>
    <config version="2" xmlns="http://mediatomb.cc/config/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/2 http://mediatomb.cc/config/2.xsd"><!--
         Read /usr/share/doc/mediatomb-common/README.gz section 6 for more
         information on creating and using config.xml configration files.
        -->
      <server>
        <ui enabled="yes" show-tooltips="yes">
          <accounts enabled="no" session-timeout="30">
            <account user="mediatomb" password="mediatomb"/>
          </accounts>
        </ui>
        <name>MSI MediaTomb</name>
        <udn>uuid:ef36ddbb-65a9-45c0-b286-e4f56aa61712</udn>
        <home>/var/lib/mediatomb</home>
        <webroot>/usr/share/mediatomb/web</webroot>
        <storage caching="yes">
          <sqlite3 enabled="yes">
            <database-file>mediatomb.db</database-file>
          </sqlite3>
          <mysql enabled="no">
            <host>localhost</host>
            <username>mediatomb</username>
            <database>mediatomb</database>
          </mysql>
        </storage>
        <protocolInfo extend="no"/><!-- For PS3 support change to "yes" --><!--
           Uncomment the lines below to get rid of jerky avi playback on the
           DSM320 or to enable subtitles support on the DSM units
        --><!--
        <custom-http-headers>
          <add header="X-User-Agent: redsonic"/>
        </custom-http-headers>
        <manufacturerURL>redsonic.com</manufacturerURL>
        <modelNumber>105</modelNumber>
        --><!-- Uncomment the line below if you have a Telegent TG100 --><!--
           <upnp-string-limit>101</upnp-string-limit>
        -->
        <extended-runtime-options>
          <ffmpegthumbnailer enabled="yes">
            <thumbnail-size>128</thumbnail-size>
            <seek-percentage>5</seek-percentage>
            <filmstrip-overlay>yes</filmstrip-overlay>
            <workaround-bugs>no</workaround-bugs>
          </ffmpegthumbnailer>
          <mark-played-items enabled="no" suppress-cds-updates="yes">
            <string mode="prepend">*</string>
          </mark-played-items>
        </extended-runtime-options>
      </server>
      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <common-script>/usr/share/mediatomb/js/common.js</common-script>
          <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
          <virtual-layout type="builtin">
            <import-script>/usr/share/mediatomb/js/import.js</import-script>
            <dvd-script>/usr/share/mediatomb/js/import-dvd.js</dvd-script>
          </virtual-layout>
        </scripting>
        <mappings>
          <extension-mimetype ignore-unknown="no">
            <map from="mp3" to="audio/mpeg"/>
            <map from="ogg" to="application/ogg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="m3u" to="audio/x-mpegurl"/>
            <map from="pls" to="audio/x-scpls"/>
            <map from="flv" to="video/x-flv"/>
            <map from="mkv" to="video/x-matroska"/>
            <map from="mka" to="audio/x-matroska"/><!-- Uncomment the line below for PS3 divx support -->
        <map from="avi" to="video/divx"/> --><!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 --><!-- <map from="avi" to="video/avi"/> -->
          </extension-mimetype>
          <mimetype-upnpclass>
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
            <map from="application/ogg" to="object.item.audioItem.musicTrack"/>
          </mimetype-upnpclass>
          <mimetype-contenttype>
            <treat mimetype="audio/mpeg" as="mp3"/>
            <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="audio/L16" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
            <treat mimetype="video/mp4" as="mp4"/>
            <treat mimetype="audio/mp4" as="mp4"/>
            <treat mimetype="application/x-iso9660" as="dvd"/>
            <treat mimetype="application/x-iso9660-image" as="dvd"/>
            <treat mimetype="video/x-matroska" as="mkv"/>
            <treat mimetype="audio/x-matroska" as="mka"/>
          </mimetype-contenttype>
        </mappings>
        <online-content><!-- Make sure to setup a transcoding profile for flv -->
          <YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude" format="flv" hd="no">
            <favorites user="mediatomb"/>
            <standardfeed feed="most_viewed" time-range="today"/>
            <playlists user="mediatomb"/>
            <uploads user="mediatomb"/>
            <standardfeed feed="recently_featured" time-range="today"/>
          </YouTube>
          <Weborama enabled="no" refresh="28800" update-at-start="no">
            <playlist name="Active" type="playlist" mood="active"/>
            <playlist name="Metal" type="playlist">
              <filter>
                <genres>metal</genres>
              </filter>
            </playlist>
          </Weborama>
          <AppleTrailers enabled="no" refresh="43200" update-at-start="no" resolution="640"/>
        </online-content>
      </import>
      <transcoding enabled="yes">
        <mimetype-profile-mappings>
          <transcode mimetype="video/x-flv" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
        </mimetype-profile-mappings>
        <profiles>
          <profile name="oggflac2raw" enabled="no" type="external">
            <mimetype>audio/L16</mimetype>
            <accept-url>no</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          </profile>
          <profile name="vlcmpeg" enabled="no" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>yes</accept-ogg-theora>
            <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
          </profile>
        </profiles>
      </transcoding>
    </config>
    

    все работает, но примерно через минут 10 воспроизведения телек выдает сообщение об отключении сервера и перестает видеть сервер. Чтобы вновь телек увидел серкак нужно его перезапустить. Как это вылечить?

     
1 2 3 > >> (Page 1 of 3)