asx to MP3

Help
Anonymous
2010-02-27
2013-05-30

  • Anonymous
    2010-02-27

    I have been trying without success to transcode an asx radio feed to MP3.  Here are the steps that I followed:

    1) Feed I am trying to transcode: http://asx.abacast.com/centralontariobroadcasting-rock95fm-32.asx?ref=js&embedded=true&timeout=false&uofc=false

    2) In the database I have the following info:  Protocol: http;  Class: object.item.audioItem.musicTrack,  mimetype: audio/video/x-ms-asx

    3) config.xml :  in Mapping:  <map from="asx" to="audio/video/x-ms-asx"/>
                               In mimetype contenttype :   <treat mimetype="audio/video/x-ms-asx" as="asx"/>
                               In transcoding:  <transcode mimetype="audio/video/x-ms-asx" using="audio-generic"/>
                               In Profile:  <profile name="audio-generic" enabled="yes" type="external">
            <mimetype>audio/mpeg</mimetype>
            <first-resource>yes</first-resource>
            <accept-url>yes</accept-url>
            <sample-frequency>44100</sample-frequency>
            <audio-channels>2</audio-channels>
            <hide-original-resource>yes</hide-original-resource>
            <agent command="ffmpeg" arguments="-ac 2 -ar 44100 -y -i %in -f mp3 %out"/>
            <buffer size="1048576" chunk-size="4096" fill-size="1024"/>
          </profile>

    Now FFMpeg complains of unknown format so obviously I am doing something wrong here; see printout below:

    010-02-27 00:28:19    INFO: Arguments: -ac 2 -ar 44100 -y -i %in -f mp3 %out
    FFmpeg version SVN-r19352-4:0.5+svn20090706-2ubuntu2, Copyright (C) 2000-2009 Fabrice Bellard, et al.
      configuration: -extra-version=4:0.5+svn20090706-2ubuntu2 -prefix=/usr -enable-avfilter -enable-avfilter-lavf -enable-vdpau -enable-bzlib -enable-libgsm -enable-libschroedinger -enable-libspeex -enable-libtheora -enable-libvorbis -enable-pthreads -enable-zlib -disable-stripping -disable-vhook -enable-gpl -enable-postproc -enable-swscale -enable-x11grab -enable-libdc1394 -extra-cflags=-I/build/buildd/ffmpeg-0.5+svn20090706/debian/include -enable-shared -disable-static
      libavutil     49.15. 0 / 49.15. 0
      libavcodec    52.20. 0 / 52.20. 0
      libavformat   52.31. 0 / 52.31. 0
      libavdevice   52. 1. 0 / 52. 1. 0
      libavfilter    0. 4. 0 /  0. 4. 0
      libswscale     0. 7. 1 /  0. 7. 1
      libpostproc   51. 2. 0 / 51. 2. 0
      built on Oct 13 2009 22:15:16, gcc: 4.4.1
    http://asx.abacast.com/centralontariobroadcasting-rock95fm-32.asx?ref=js&embedded=true&timeout=false&uofc=false : Unknown format

    Any help would be appreciated; I know that the feed link is fine since VLC play that feed without any problems.  How can I make FFMpeg happy with the I/P I am given it.  The profile is also correct since I use the same one for some radio station streaming using the ogg format.

    Thanks

                              

     
  • Jin
    Jin
    2010-02-28

    I am not sure you can, ffmpeg is not very good at handling online media. Why don't you use VLC instead - it does work. However I am not sure if it can properly transcode to LPCM or not, at least I remember there was a bug and people had some problems with it.

    You could also try mplayer instead…

     
  • I have the same challange; try to stream http://www.skyradio.nl/player/skyradio.asx. Via mediatomb UI I can listen to it using VLC but not on my PHILIPS SLA5520.

    I'm sure it's a config.xml issue, but I just don know how to do it. Googling just didn help ;) any help is appreciated!!