WD TV Live plus doesn't see mediatomb

  • dave

    I am using Fedora Core 14 and installed mediatomb though the add software menu.

    I started mediatomb (see below) it starts without errors, but my WD TV live plus media center doesn't see it when I search for media servers.

    I was able to get it to connect and use PlayOn running on a Windows PC. I am able to ping the WD media center from the PC running mediatomb and I'm not sure what's happening.

    I also executed the following:
    route add -net netmask eth0
    ifconfig eth0 allmulti

    Does anyone have any advice?

    MediaTomb UPnP Server version 0.12.1 - http://mediatomb.cc/

    Copyright 2005-2010 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
    MediaTomb is free software, covered by the GNU General Public License version 2

    2011-01-07 15:00:37    INFO: Loading configuration from: /home/dave/.mediatomb/config.xml
    2011-01-07 15:00:37    INFO: Checking configuration…
    2011-01-07 15:00:37    INFO: Setting filesystem import charset to UTF-8
    2011-01-07 15:00:37    INFO: Setting metadata import charset to UTF-8
    2011-01-07 15:00:37    INFO: Setting playlist charset to UTF-8
    2011-01-07 15:00:37 WARNING: You enabled the YouTube feature, which allows you
                                 to watch YouTube videos on your UPnP device!
                                 Please check http://www.youtube.com/t/terms
                                 By using this feature you may be violating YouTube
                                 service terms and conditions!

    2011-01-07 15:00:37    INFO: Configuration check succeeded.
    2011-01-07 15:00:37    INFO: Initialized port: 49152
    2011-01-07 15:00:37    INFO: Server bound to:
    2011-01-07 15:00:38    INFO: MediaTomb Web UI can be reached by following this link:
    2011-01-07 15:00:38    INFO:

  • Which version of mediatomb are you running on F14? Make sure it's 0.12.1-4 'cause previous ones had problems. Also, I noticed that mediatomb crashes on some playlists which have incorrectly translated special characters, like French and Italian accented letters. Personally, I found it easier to manually amend those playlists and it now runs fine. Also, open ports 1900 and 50500 TCP/UDP on your Fedora box.