mediatomb 0.9.1 on OS X - libmagic problem?

Help
2007-07-19
2013-05-30
  • Eray Ozkural
    Eray Ozkural
    2007-07-19

    Hi there,

    I have successfully run mediatomb on OS X using the official fink packages.

    However, I suspect that the libmagic support is not working. Well, couldn't find a libmagic on my system anyhow. :)

    Right now I can play mp3s on PS3, but nothing else is properly recognized so I can't play mp4's or show jpgs. They all show up as octet-stream so the PS3 won't play them.

    Any help would be appreciated.

    Cheers,

    Eray

     
    • Jin
      Jin
      2007-07-20

      I have no OS X system, so I can only guess how this works - I think you compile the Fink packages, right? You do not download binaries?

      Make sure that you have the "file" package with development headers installed before compiling MediaTomb. Theoretically you could live without libmagic (allthough it makes things much easier) - you could add extension to mimetype mappings in your config.xml and reimport your media. Also, make sure to add the protocolInfo parameter to your configuration (it's required for PS3 support)

      Rgds,
      Jin

       
    • Eray Ozkural
      Eray Ozkural
      2007-07-20

      Hi Jin,

      Oh, I thought (naively?) that fink installed source dependencies as well. Kind of weird. Let me check.

      Best,

      Eray

       
    • Jin
      Jin
      2007-07-21

      To be honest - I have no idea :) Since libmagic is optional it is possible that it is not enforced... I have to ask the Fink people on how this exactly works. It is difficult for me, because I do not have an OS X system.

       
    • aqq
      aqq
      2007-07-25

      i could succesfully compile everything on my imac ppc, first you need xcode, then install darwinports (macports) and
      do the instructions to use (selfupdate and so on) , port install command

      libmagic is included in the "file" package, i couldn t find it either, only another libmagic homepage but thats wrong

      so after you have macports ready type : sudo port install file, it will update the file command(package?) to the latest version where libmagic is included. after that i recommend you install spidermonkey too. sudo port install spidermonkey was the command i think, at the end compile mediatomb again and see ,everythink works

      i am running mediatomb with all recommend librarys except taglib and libextractor, it works great with my ps3 , thank you very much jin and all who help and support this project ! thumbs up !!!

      i have also a gentoo linux system, both works great but my hole media is on my os x machine. in compare with this twonky thing mediatomb works better for me !

       
    • Jin
      Jin
      2007-07-25

      Thanks for the feedback, great to hear that it works!

      Actually, when porting MT I also used darwinports, only later I got in touch with Fink developers who then added MediaTomb to Fink (thanks RangerRick!)