Samsung C5000

Help
2011-03-29
2013-05-30
  • I got my Samsung C5000 working with mediatomb. The only problem is that during playback AVI file container (MPEG4 as video and MP3 as audio) "Unrecognised file format" is raported. Can anybody help me in proper config.xml edition?

    So is my config.xml file:

    <?xml version="1.0" encoding="UTF-8"?>
    <config version="2" xmlns="http://mediatomb.cc/config/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/2 http://mediatomb.cc/config/2.xsd">
      <server>
    <port>88</port>
        <ui enabled="yes" show-tooltips="yes">
          <accounts enabled="yes" session-timeout="30">
            <account user="mediatomb" password="mediatomb"/>
          </accounts>
        </ui>
        <name>Media</name>
        <udn>uuid:d7eb0fd3-59aa-44ba-91d3-f8dacf1f34a6</udn>
        <home>/root/.mediatomb</home>
        <webroot>/usr/share/mediatomb/web</webroot>
        <storage>
          <sqlite3 enabled="yes">
            <database-file>mediatomb.db</database-file>
          </sqlite3>
        </storage>
        <protocolInfo extend="yes"/><!- For PS3 support change to "yes" ->
        <!-
           Uncomment the lines below to get rid of jerky avi playback on the
           DSM320 or to enable subtitles support on the DSM units
        ->
        <!-
        <custom-http-headers>
          <add header="X-User-Agent: redsonic"/>
        </custom-http-headers>

        <manufacturerURL>redsonic.com</manufacturerURL>
        <modelNumber>105</modelNumber>
        ->
        <!- Uncomment the line below if you have a Telegent TG100 ->
        <!-
           <upnp-string-limit>101</upnp-string-limit>
        ->

    <custom-http-headers>
    <add header="transferMode.dlna.org: Streaming"/>
    <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000"/>
    </custom-http-headers>

        <extended-runtime-options>
          <mark-played-items enabled="yes" suppress-cds-updates="yes">
            <string mode="prepend">*</string>
            <mark>
              <content>video</content>
            </mark>
          </mark-played-items>
        </extended-runtime-options>
      </server>
      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <virtual-layout type="builtin"/>
        </scripting>
        <mappings>
          <extension-mimetype ignore-unknown="no">
            <map from="mp3" to="audio/mpeg"/>
            <map from="ogx" to="application/ogg"/>
            <map from="ogv" to="video/ogg"/>
            <map from="oga" to="audio/ogg"/>
            <map from="ogg" to="audio/ogg"/>
            <map from="ogm" to="video/ogg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="m3u" to="audio/x-mpegurl"/>
            <map from="pls" to="audio/x-scpls"/>
            <map from="flv" to="video/x-flv"/>
            <map from="mkv" to="video/x-matroska"/>
            <map from="mka" to="audio/x-matroska"/>
            <!- Uncomment the line below for PS3 divx support ->
             <map from="avi" to="video/divx"/>
            <!- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 ->
            <!- <map from="avi" to="video/avi"/> ->
          </extension-mimetype>
          <mimetype-upnpclass>
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
          </mimetype-upnpclass>
          <mimetype-contenttype>
            <treat mimetype="audio/mpeg" as="mp3"/>
            <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="audio/L16" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
            <treat mimetype="video/mp4" as="mp4"/>
            <treat mimetype="audio/mp4" as="mp4"/>
            <treat mimetype="application/x-iso9660" as="dvd"/>
            <treat mimetype="application/x-iso9660-image" as="dvd"/>
          </mimetype-contenttype>
        </mappings>
        <online-content>
          <YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude" format="mp4" hd="no">
            <favorites user="mediatomb"/>
            <standardfeed feed="most_viewed" time-range="today"/>
            <playlists user="mediatomb"/>
            <uploads user="mediatomb"/>
            <standardfeed feed="recently_featured" time-range="today"/>
          </YouTube>
        </online-content>
      </import>
      <transcoding enabled="no">
        <mimetype-profile-mappings>
          <transcode mimetype="video/x-flv" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
        </mimetype-profile-mappings>
        <profiles>
          <profile name="oggflac2raw" enabled="no" type="external">
            <mimetype>audio/L16</mimetype>
            <accept-url>no</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          </profile>
          <profile name="vlcmpeg" enabled="no" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>yes</accept-ogg-theora>
            <agent command="vlc" arguments="-I dummy %in -sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
          </profile>
        </profiles>
      </transcoding>
    </config>

     
  • BT
    BT
    2011-03-29

    You need to change <map from="avi" to="video/divx"/> to <map from="avi" to="video/x-msvideo"/>. You will also need to remove all content from the MediaTomb database and import again.

     
  • THX! It works! Now I have simmilar problem with mkv files. Cant You help once more?

     
  • BT
    BT
    2011-03-30

    Change <map from="mkv" to="video/x-matroska"/> to <map from="mkv" to="video/mpeg"/>. Just like before you need to re-import your content again.

     
  • YOU ARE GREAT! It simply works! THX!

     
  • Hi All,

    I have a similar issue with a Samsung TV LED Series 7. Using the > or < buttons will not move the movie as expected Fwd and Bkwd. I am using .ts files with mpeg2 content and in my config file I map ts to video/mpeg!

    Is there another mapping I should use?

    I have tried it with my ps3 and here it works fine :-|

    /Anders

     
  • Can You send me the line how to map ts file to mpeg?

     
  • I use the following line:

    <map from="ts" to="video/mpeg"/>

    Works to play and as well the fwd and bkwd on PS3 but just to play pause etc on the Samsung TV

    BR /Anders

     
  • THX !!!

     
  • My BD-C5500 won't play flac files.

    I've turned on flac transcoding in config.xml, but no luck as I'm guessing the player doesn't recognize "audio/L16" as a format it likes.

    Can I get some advice how to debug this?