Streaming external content

  • Chris

    Hello, I am trying to stream from a computer on my network to my mediatomb server. Mediatomb is working fine (im streaming normally from the server to a Samsung TV). I have checked via other computers I am able to open the file remotely via vlc so all I really need to do is set up some link on the mediatomb database to this stream.

    I tried to setup an external link, the http address is definitely correct, i gave it the following

    title:  sop.asf
    protocol: http-get
    class: object.item
    description: sop.avi
    mime: video/x-ms-asf

    but when i try and access it on the dlna tv i dont see the link. I havent changed my config settings as i couldn't find any docs on it.

    Any ideas?



  • Chris

    Ok  I managed to get the link to be viewed on the tv (had to change the class to object.item.videoItem). I tried to open it and of course I got a file not supported error, so I start looking at transcoding. I know I can open the stream remotely as I have said, I tried setting up transcoding but still not supported.

    So then I tried to use the transcoder on the command line (both ffmpeg and vlc) to pipe the transcoded stream to a file in the mediatomb database. This worked but the player will only play the amount that has been buffered since I started transcoding (i.e. the end of the fifo pipe at that the point i start viewing).

    Would using an external container solve this issue for me so I can see this continually streamed? If so any ideas what im doing wrong with the transcoding settings? I have attached them below and I have also tried transcoding with accept-url set to yes:

      <transcoding enabled="yes">
          <transcode mimetype="video/x-ms-asf" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
          <profile name="oggflac2raw" enabled="no" type="external">
            <agent command="ogg123" arguments="-d raw -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          <profile name="vlcmpeg" enabled="yes" type="external">
            <agent command="vlc" arguments="-I dummy %in -sout '#transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out}' vlc:quit"/>
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>