Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Transcoding works with one player, not anothe

Help
2011-08-04
2013-05-30
  • Martin Giese
    Martin Giese
    2011-08-04

    I've setup mediatomb with the univsersal transcoding scripts from http://www.vanalboom.org/node/14 and http://www.vanalboom.org/node/16. 

    Works fine, all movies are registered with a mime type of video/transcode.  If I run VLC, I can browse the media server, and if I play a file, it gets transcoded.  I can see the mencoder process doing the transcoding, I can see what happens in the log, and VLC tells me it's decoding MPEG video where the file system contained something different.

    Now I connected my Grundig TV to the same machine, and mysteriously, it sees the original (untranscoded) versions of the files.  No transcoding process runs on my machine, nothing is written to the transcoding log.  I can play the files that have containers and codecs the TV supports, but only those.  As if the transcoding had never been activated.

    Any ideas?  Can mediatomb ignore the transcoding request for some clients but not for others!?

     
  • l0co
    l0co
    2011-12-22

    Have you found a solution since?

     
  • l0co
    l0co
    2011-12-22

    OK, I've found the problem. Some players apparently look for the original resource, you need to apply:

    <hide-original-resource>yes</hide-original-resource>
    

    To the transoding profile, see http://mediatomb.cc/pages/transcoding.