Mediatomb and Dhcp3-server + bind-9

Help
Rodomar705
2010-11-02
2013-05-30
  •  Rodomar705
    Rodomar705
    2010-11-02

    I've a problem since i've set up that two services…

    The service start correctly, i can open the interface on port 49152 inside the small lan that i've set up for video sharing with my WD TV, but the service in the interface of all DLNA client don't appear (Neither in the WD-TV, nor with VLC on a PC).

    I've search for a week, but i can't get it working.

    By the way, i've followed this tutorial for configuration:

    http://www.howtoforge.com/nat-gateway-iptables-port-forwarding-dns-and-dhcp-setup-ubuntu-8.10-server

    Anybody can help me?

    Thanks a lot, and sorry for my english, i'm italian

    Rodomar705

     
  • Jin
    Jin
    2010-11-20

    Maybe you have several network interfaces and MT binds to the wrong one? Double check that, it's possible that you hit this problem.

     
  •  Rodomar705
    Rodomar705
    2010-11-21

    You're perfecly right, i've two interefaces (wlan0 and eth0) and the mediaserver won't work if i don't specify the ip of the interface that i want to use.

    But i can bind MediaTomb with more than one interface? For example on every interface in my network (first post for my lan configuration)?

    Thank a lot (and sorry for my english, i'm italian),

    Rodomar705

     
  • Jin
    Jin
    2010-11-21

    libupnp does not support binding to multiple interfaces; well, actually - the websrever (UI) will be available an all interfaces, but the SSDP part will work only on one interface. So if you really want to make MT available on two network interfaces, you will have to run two instances of MediaTomb, both need to use a separate config.xml and a separate database.