Ubuntu mediatomb package

Help
2010-10-02
2013-05-30
  • Hi,
    JS support is deactivated in Ubuntu mediatomb package since 10.04.
    They stated that it was not easily possible to compile angainst xulrunner instead of libmozjs:_

    "This was disabled deliberately because it was still depending on libmozjs, which we removed ages ago. It doesn't build against the latest xulrunner because it hard-codes header paths rather than using pkg-config, and is looking in all the wrong places for headers. I don't have the time to fix this, so it was a choice between disabling spidermonkey support or dropping it from the archive altogether"_

    Please see: https://bugs.launchpad.net/ubuntu/+source/mediatomb/+bug/568275

    Is there any chance from the mediatomb guys to help the ubuntu guys to have js support for mediatomb easily back again?
    -> maybe by hard coded things…

     
  • Sean Mullen
    Sean Mullen
    2010-11-01

    Hi, I had the same issue.  I've built my own to get around things.  Here's my notes for how to build it with just about everything enabled.  In the below notes, you have to replace the xulrunner version with your own and then export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/xulrunner-1.9.2.11 (with your xulrunner version) in your init script for mediatomb :
    #build and install ffmpegthumbnailer
    svn checkout http://ffmpegthumbnailer.googlecode.com/svn/trunk/ ffmpegthumbnailer
    cd ffmpegthumbnailer
    ./autogen.sh
    ./configure -enable-shared
    make
    sudo checkinstall -fstrans=no -install=yes -pkgname=ffmpegthumbnailer -pkgve
    rsion "2.0.0.svn`date +%Y%m%d`-0.0ubuntu1" -default

    #libmp4v2
    svn checkout http://mp4v2.googlecode.com/svn/trunk/ mp4v2
    cd mp4v2
    autoreconf -i
    ./configure
    make
    sudo checkinstall -fstrans=no -install=yes -pkgname=libmp4v2-0 -pkgversion "
    1:1.9svn383-0.2ubuntu8" -default

    #libjs (spidermonkey) is in xulrunner now.
    sudo apt-get install xulrunner-dev

    #install either MySQL or sqlite3
    apt-get install libsqlite3-dev libmysqlclient-dev libmagic-dev libexif-dev libcu
    rl4-gnutls-dev

    #build and install Mediatomb
    svn co https://svn.mediatomb.cc/svnroot/mediatomb/trunk/mediatomb mediatomb
    cd mediatomb
    autoreconf -i
    ./configure -with-js-h=/usr/include/xulrunner-1.9.2.11 -with-js-libs=/usr/lib/x
    ulrunner-1.9.2.11
    edit src/mxml/parser.h
       change expat.h to /usr/include/expat.h
    make
    sudo checkinstall -fstrans=no -install=yes -pkgname=mediatomb -pkgversion "0
    .12.0~svn2102-6ubuntu2" -default

     
  • Hi, thanks for the reply.

    I already try to compile myself but stop to continue when i saw how many packages are depend on xulrunner:

    OVER 80 packages just for this!!!!

    Do you know if this is really needed?