No metadata

Help
2007-05-07
2013-05-30
  • Hi,

    I have only .flac audio files on my disk. The files are scanned from disk and stored in the database. But the metadata is not read from the files. The files appear only in "unknown" folders. ("Audio/Albums/unknown", "Audio/Artists/unknown" etc.)The metadata are stored in the files, I can see them e.g. with konqueror.

    I have installed mediatomb for Debian AMD64 from the deb-src source. It works fine.

    Thanks for help
    Michael

     
    • Jin
      Jin
      2007-05-07

      Well... I fear you will have to compile a version yourself then :) We do have taglib support, this library can handle metadata for flac files; however we had some problems with it. We had reports that it was crashing on specific mp3 files and it seemed to leak some memory. Therefore we decided to use id3lib by default - it proved to be very stable, however it can not handle ogg and flac metadata.

      Nevertheless, we provide taglib support, so simply recompile mediatomb giving the --enable-taglib parameter to the configure script.

      Btw good to hear that it works on AMD64, we noticed some warnings when compiling, mostly in the upnp part of the code, that's certainly something that I will have to clean up.

      Greetings,
      Jin

       
    • Thanks for your answer Jin.

      Yes, I will try to compile it with the taglib support.

      Michael

       
    • Hello,

      now I compiled with taglib support, but I had a problem with the "debian way" and the "deb-src" files.

      First I downloaded with apt the deb-src, changed in debian/rules the config options (added --enable-taglib), but it didn't compile with taglib.

      Only with the original ..tar.gz source it works with taglib, also the "debian way"
      (With dh_make I made the debian folders, changed the rules file made and installed the .deb file, and now it works with taglib)

      Why not with the debian-source?

      Charset: I also have the problems with taglib and the metadata charset. My system is a utf-8 system, but I had to set metadata charset to 8859-15. Is this a problem with the flac decoder?

      First impression: Great program!!!

      Now I need a renderer, has someone the new Netgear EVA8000? Some experience with flac files and the EVA8000?

      Michael

       
      • Leo
        Leo
        2007-05-11

        Hi,

        I cannot reproduce your problem with deb-src and taglib. I did the following:

        * checked out with "apt-get source mediatomb"
        * added "--enable-taglib" to the "./configure" line in the "rules" file
        * addded "libtag1-dev" to the "Build-Depends" in the "control" file
        * removed "libid3" from the "Build-Depends"

        .. and it worked. Does this work for you?

        greets,
        Leo

         
    • Jin
      Jin
      2007-05-10

      Leo will reply to the debian related questions.
      Regarding the charset:
      we use UTF-8 internally, that means that we have to convert any incoming strings into UTF-8; in order to do that correctly we have to know the original charset. By default we try to determine that based on the system locale; however in your case the system uses UTF-8, but the actual metadata in the audio files was saved in a different charset. That's what the metadata-charset is for, so you did everything correctly there, by using this setting.

      I do not know what was used to produce those flac files and I also do not know much about flac metadata options, so I can not tell you if you could update the flac files to UTF-8 metadata strings.

      Greetings,
      Jin

       
    • Hi,

      Leo
      >* addded "libtag1-dev" to the "Build-Depends" in the "control" file
      >* removed "libid3" from the "Build-Depends"

      I didn't change these two lines. Pherhaps this was the problem. When I compile the next Version (1.0?), I'll try this, because mediatomb works fine now. In the debian control file from the original tar.gz. source is no libid3 dependency, so I think therfore it works now.

      Jin,
      >I do not know what was used to produce those flac files and I also do not know much about flac metadata options, so >I can not tell you if you could update the flac files to UTF-8 metadata strings.

      I tested a tag editor (easytag, fine program), there I can choose whether the tags shoul save in 8859-1 or UTF-8. For ID3 tags I think the 8859-1 charset is standard, because the ID3-1 Version needs 1 Byte charsets. With UTF-8 you can't use the ID3-1 Version. (So it is described in easytag)

      Thanks Michael

       
    • Jin
      Jin
      2007-05-11

      >I tested a tag editor (easytag, fine program), there I can choose whether the tags shoul save in 8859-1 or
      >AUTF-8. For ID3 tags I think the 8859-1 charset is standard, because the ID3-1 Version needs 1 Byte charsets. >
      >With UTF-8 you can't use the ID3-1 Version. (So it is described in easytag)

      I see... well, there is a little problem with mixed charsets: currently you can only specify the metadata charset in the servers config file; we plan introduce an "import as xxx charset" feature, so you could select the import charset in the UI before importing a specific directory or specific files. Currently you would have to change the setting in config.xml and restart the server, which is not very convenient.

      Greetings,
      Jin

       
    • Jin wrote
      ..
      >plan introduce an "import as xxx charset" feature, so you could select the import charset in the UI before >importing a specific directory or specific files. Currently you would have to change the setting in config.xml and
      >restart the server, which is not very convenient.

      I have no problems with 8859-15 anyway, although I choose UTF-8 in Easytag for the ID3 Tags.

      Greetings
      Michael