Samsung LN46C610 + Ubuntu 10.04 Lucid

Help
M
2011-03-05
2013-05-30
  • M
    M
    2011-03-05

    Just bought Samsung LN46C610 and installed Mediatomb 0.012.0~svn2018_6ubuntu2 (lucid) from repos.

    After modifying config file as per other Samsung/Ubuntu users posts, the TV sees Mediatomb and all folder are visible but attempts to play/view files results in "File Format not Supported".

    When I place the same files on a USB memory stick, they play fine from the stick.

    The TV and my computer are connected through a wired network which includes a DLINK WBR-2310 router and a LINKSYS 5-port switch.

    Here is my log file:

    2011-03-05 11:38:28    INFO: Loading configuration from: /etc/mediatomb/config.xml
    2011-03-05 11:38:29    INFO: Checking configuration...
    2011-03-05 11:38:29    INFO: Setting filesystem import charset to ANSI_X3.4-1968
    2011-03-05 11:38:29    INFO: Setting metadata import charset to ANSI_X3.4-1968
    2011-03-05 11:38:29    INFO: Setting playlist charset to ANSI_X3.4-1968
    2011-03-05 11:38:29    INFO: Configuration check succeeded.
    2011-03-05 11:38:29    INFO: Initialized port: 49152
    2011-03-05 11:38:29    INFO: Server bound to: 192.168.0.100
    2011-03-05 11:38:30    INFO: MediaTomb Web UI can be reached by following this link:
    2011-03-05 11:38:30    INFO: http://192.168.0.100:49152/
    2011-03-05 12:10:36   ERROR: ActionRequest::update(): response is nil, code -115
    2011-03-05 12:10:36   ERROR: ActionRequest::update(): response is nil, code -115
    

    and here is my Config file:

    I admit that I have modified the config file a few times as when I invoked mediatomb from CLI there were a few parsing errors due to mis-matched tags. Perhaps I have messed it up?

    <?xml version="1.0" encoding="UTF-8"?>
    <config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd">
      <!--
         Read /usr/share/doc/mediatomb-common/README.gz section 6 for more
         information on creating and using config.xml configration files.
        -->
      <server>
        <ui enabled="yes" show-tooltips="yes">
          <accounts enabled="no" session-timeout="30">
            <account user="mediatomb" password="mediatomb"/>
          </accounts>
        </ui>
        <name>MediaTomb</name>
        <udn>uuid:b4b208e6-def9-4250-8c06-b36d839dff7a</udn>
        <home>/home/michael/.mediatomb</home>
        <webroot>/usr/share/mediatomb/web</webroot>
        <storage>
          <sqlite3 enabled="yes">
            <database-file>mediatomb.db</database-file>
          </sqlite3>
          <mysql enabled="no">
            <host>localhost</host>
            <username>mediatomb</username>
            <database>mediatomb</database>
          </mysql>
        </storage>
        <protocolInfo extend="yes"/><!-- For PS3 support change to "yes" -->
        <!--
           Uncomment the lines below to get rid of jerky avi playback on the
           DSM320 or to enable subtitles support on the DSM units
        -->
        <custom-http-headers>
        <add header="transferMode.dlna.org: Streaming"/>
        <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=017000 00000000000000000000000000"/>
        <!-- Uncomment the line below if you have a Telegent TG100 -->
           <upnp-string-limit>101</upnp-string-limit>
        <extended-runtime-options>
          <ffmpegthumbnailer enabled="no">
            <thumbnail-size>128</thumbnail-size>
            <seek-percentage>5</seek-percentage>
            <filmstrip-overlay>yes</filmstrip-overlay>
            <workaround-bugs>no</workaround-bugs>
          </ffmpegthumbnailer>
          <mark-played-items enabled="no" suppress-cds-updates="yes">
            <string mode="prepend">*</string>
          </mark-played-items>
        </extended-runtime-options>
      </server>
      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <virtual-layout type="builtin"/>
        </scripting>
        <mappings>
          <extension-mimetype ignore-unknown="no">
        <map from="avi" to="video/mpeg"/>        
        <map from="mp3" to="audio/mpeg"/>
            <map from="ogg" to="application/ogg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="m3u" to="audio/x-mpegurl"/>
            <map from="pls" to="audio/x-scpls"/>
            <map from="flv" to="video/x-flv"/>
            <map from="mkv" to="video/mpeg"/>
            <map from="mka" to="audio/x-matroska"/>
        <map from="avi" to="video/divx"/>
        <map from="avi" to="video/avi"/>
          </extension-mimetype>
          <mimetype-upnpclass>
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
            <map from="application/ogg" to="object.item.audioItem.musicTrack"/>
          </mimetype-upnpclass>
          <mimetype-contenttype>
            <treat mimetype="audio/mpeg" as="mp3"/>
            <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="audio/L16" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
            <treat mimetype="video/mp4" as="mp4"/>
            <treat mimetype="audio/mp4" as="mp4"/>
            <treat mimetype="application/x-iso9660" as="dvd"/>
            <treat mimetype="application/x-iso9660-image" as="dvd"/>
            <treat mimetype="video/x-matroska" as="mkv"/>
            <treat mimetype="audio/x-matroska" as="mka"/>
          </mimetype-contenttype>
        </mappings>
        <online-content>
          <YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude" format="flv" hd="no">
            <favorites user="mediatomb"/>
            <standardfeed feed="most_viewed" time-range="today"/>
            <playlists user="mediatomb"/>
            <uploads user="mediatomb"/>
            <standardfeed feed="recently_featured" time-range="today"/>
          </YouTube>
          <Weborama enabled="no" refresh="28800" update-at-start="no">
            <playlist name="Active" type="playlist" mood="active"/>
            <playlist name="Metal" type="playlist">
              <filter>
                <genres>metal</genres>
              </filter>
            </playlist>
          </Weborama>
          <AppleTrailers enabled="no" refresh="43200" update-at-start="no" resolution="640"/>
        </online-content>
      </import>
      <transcoding enabled="no">
        <mimetype-profile-mappings>
          <transcode mimetype="video/x-flv" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
        </mimetype-profile-mappings>
        <profiles>
          <profile name="oggflac2raw" enabled="no" type="external">
            <mimetype>audio/L16</mimetype>
            <accept-url>no</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          </profile>
          <profile name="vlcmpeg" enabled="no" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>yes</accept-ogg-theora>
            <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
          </profile>
        </profiles>
      </transcoding>
    </config>
    
     
  • letzter3
    letzter3
    2011-03-11

    The same here with the follow devices:

    TV: Samsung UE46C6700 http://www.samsung.de/de/Privatkunden/TVHeimkino/Fernseher/LEDTV/ue46c6700/UE46C6700USXZG/detail.aspx?atab=specifications
    Files: Vidoes as avi and mp4; Musik as mp3; pictures as jpg
    System: MDV 2010.2 64bit

    2011-03-10 16:42:03 INFO: Loading configuration from: /etc/mediatomb/config.xml
    2011-03-10 16:42:03 INFO: Checking configuration...
    2011-03-10 16:42:03 INFO: Setting filesystem import charset to UTF-8
    2011-03-10 16:42:03 INFO: Setting metadata import charset to UTF-8
    2011-03-10 16:42:03 INFO: Setting playlist charset to UTF-8
    2011-03-10 16:42:03 INFO: Configuration check succeeded.
    2011-03-10 16:42:03 INFO: Initialized port: 50500
    2011-03-10 16:42:03 INFO: Server bound to: 192.168.0.12
    2011-03-10 16:42:04 INFO: MediaTomb Web UI can be reached by following this link:
    2011-03-10 16:42:04 INFO: [url]http://192.168.0.12:50500/
    

    and now the acces from my TV

    2011-03-10 16:43:16 ERROR: ActionRequest::update(): response is nil, code -115
    2011-03-10 16:43:16 ERROR: ActionRequest::update(): response is nil, code -115
    2011-03-10 16:43:21 ERROR: ActionRequest::update(): response is nil, code -115
    2011-03-10 16:43:21 ERROR: ActionRequest::update(): response is nil, code -115
    2011-03-10 16:43:28 ERROR: ActionRequest::update(): response is nil, code -115
    
    [root@revo ~]# mediatomb --version
    MediaTomb UPnP Server version 0.12.0 - http://mediatomb.cc/
    ===============================================================================
    Copyright 2005-2008 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
    MediaTomb is free software, covered by the GNU General Public License version 2
    [root@revo ~]# mediatomb --compile-info
    Compile info: host: x86_64-mandriva-linux-gnu; sqlite3: yes; mysql: missing libjs: yes; libmagic: yes; inotify: yes; libexif: yes; id3lib: disabled; taglib: yes; ffmpeg: yes; libmp4v2: missing; external transcoding: yes; curl: yes; YouTube: yes; SopCast: disabled; libextractor: disabled; db-autocreate: yes; debug log: yes; protocol info extensions: yes; data directory: /usr/share/mediatomb; ffmpegthumbnailer: missing
    [root@revo ~]#
    

    My config.xml

    <?xml version="1.0" encoding="UTF-8"?>
    <config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd">
      <server>
        <ui enabled="yes" show-tooltips="yes">
          <accounts enabled="no" session-timeout="30">
            <account user="mediatomb" password="mediatomb"/>
          </accounts>
        </ui>
        <name>MediaTomb</name>
        <udn>uuid:228d88b9-1fb0-45c4-b225-be990e211e6c</udn>
        <home>/etc/mediatomb</home>
        <webroot>/usr/share/mediatomb/web</webroot>
        <storage>
          <sqlite3 enabled="yes">
            <database-file>mediatomb.db</database-file>
          </sqlite3>
        </storage>
        <protocolInfo extend="yes"/><!-- For PS3 support change to "yes" -->
        <!--
           Uncomment the lines below to get rid of jerky avi playback on the
           DSM320 or to enable subtitles support on the DSM units
        -->
        <!--
        <custom-http-headers>
          <add header="X-User-Agent: redsonic"/>
          <add header="transferMode.dlna.org: Streaming"/>
          <add header="contentFeatures.dlna.org: DLNA.ORG_OP=00"/>
        </custom-http-headers>
    <custom-http-headers> 
    <add header="transferMode.dlna.org: Streaming"/> 
    <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000"/> 
    </custom-http-headers>
        <manufacturerURL>redsonic.com</manufacturerURL>
        <modelNumber>105</modelNumber>
        -->
        <!-- Uncomment the line below if you have a Telegent TG100 -->
        <!--
           <upnp-string-limit>101</upnp-string-limit>
        -->
      </server>
      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <common-script>/usr/share/mediatomb/js/common.js</common-script>
          <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
          <virtual-layout type="builtin">
            <import-script>/usr/share/mediatomb/js/import.js</import-script>
          </virtual-layout>
        </scripting>
        <mappings>
          <extension-mimetype ignore-unknown="no">
            <map from="mp2t" to="video/mpeg"/>
            <map from="ts" to="video/mpeg"/>
            <map from="mpg" to="video/mpeg"/>
            <map from="avi" to="video/mpeg"/>
            <map from="mkv" to="video/mpeg"/>
            <map from="mp3" to="audio/mpeg"/>
            <map from="ogg" to="application/ogg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="m3u" to="audio/x-mpegurl"/>
            <map from="pls" to="audio/x-scpls"/>
            <map from="flv" to="video/x-flv"/>
            <!-- Uncomment the line below for PS3 divx support -->
            <!-- <map from="avi" to="video/divx"/> -->
            <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
            <!-- <map from="avi" to="video/avi"/> -->
          </extension-mimetype>
          <mimetype-upnpclass>
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
          </mimetype-upnpclass>
          <mimetype-contenttype>
            <treat mimetype="audio/mpeg" as="mp3"/>
            <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="audio/L16" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
            <treat mimetype="video/mp4" as="mp4"/>
            <treat mimetype="audio/mp4" as="mp4"/>
          </mimetype-contenttype>
        </mappings>
        <online-content>
          <!-- Make sure to setup a transcoding profile for flv -->
          <YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude">
            <favorites user="mediatomb"/>
            <standardfeed feed="most_viewed" time-range="today"/>
            <playlists user="mediatomb"/>
            <uploads user="mediatomb"/>
            <standardfeed feed="recently_featured" time-range="today"/>
          </YouTube>
        </online-content>
      </import>
      <transcoding enabled="no">
        <mimetype-profile-mappings>
          <transcode mimetype="video/x-flv" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
        </mimetype-profile-mappings>
        <profiles>
          <profile name="oggflac2raw" enabled="no" type="external">
            <mimetype>audio/L16</mimetype>
            <accept-url>no</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command="ogg123" arguments="-d raw -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          </profile>
          <profile name="vlcmpeg" enabled="no" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>yes</accept-ogg-theora>
            <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
          </profile>
        </profiles>
      </transcoding>
    </config>
    
     
  • BT
    BT
    2011-03-13

    mfdc,

    I think you might be editing the wrong config.xml file. Your log file shows that MediaTomb is using /etc/mediatomb/config.xml, but the config.xml you posted appears to be from /home/michael/.mediatomb

    Which config file you need to use depends on how you start MediaTomb. If it's via an init script during startup, then you need to edit /etc/mediatomb/config.xml. If you start it manually as your user in a terminal, then edit /home/michael/.mediatomb/config.xml

     
  • M
    M
    2011-03-21

    Thanks amak79, I edited the file: /etc/mediatomb/config.xml to be the same as shown above.

    I renamed the file at /home/michael/.mediatomb  hoping that mediatomb would ignore it's existance and use the one in /etc/.mediatomb

    I restarted computer, then executed mediatomb from the command line. The result looked promising as it went thru the steps of starting up. I dialogue from CLI said a new config file was written to /home/michael/.mediatomb

    I tried to restart mediatomb from CLI using  $ sudo service mediatomb restart the result was , going to a web browser to reach mediatomb gave the error that it was not accessible on port 49153. NOTE: port 49152 was indicated in /home/michael/.mediatomb

    I edited pulled up the file at  /home/michael/.mediatomb and it was an original un-edited config so I copied the contents to be the same as /etc/.mediatomb/config.xml

    After restarting machine and executing mediatomb to rebuild the database, the error in log file persists:

    ERROR: ActionRequest::update(): response is nil, code -115

    From the TV I can see mediatomb but once again, no file will play.

     
  • BT
    BT
    2011-03-21

    Can you please paste your /etc/mediatomb/config.xml to a pastebin service like http://pastebin.com/ and post a link to it. The SF.net forum does not preserve line endings which makes it difficult to see your config.xml when I paste it into a file.

     
  • M
    M
    2011-03-22

    OK, done that and here is the link:

    http://pastebin.com/QWnpWu7W

    Note, when I try to execute mediatomb from CLI I get an error that when it reads the config file:

    ERROR: Error parsing config file: /home/michael/.mediatomb/config.xml line 49:mismatched tag
    

    Could this simply be the problem?

     
  • BT
    BT
    2011-03-22

    I'm looking at the config.xml now and there is some problems with it. I'll post a fixed version shortly.

     
  • BT
    BT
    2011-03-22

    You can find the corrected config.xml here: http://pastebin.com/2HYsCYJY

    You need to save this file as /etc/mediatomb/config.xml so you will need root access (sudo). Do not save this as /home/michael/.mediatomb/config.xml as it won't work. You should also remove the /home/michael/.mediatomb directory to avoid confusion. Make sure the file is owned by the mediatomb user and group, otherwise MediaTomb will fail to start.

    The ideal way to start MediaTomb is as a system service so that it will start when you're computer starts. You should now restart MediaTomb with sudo service mediatomb restart. You can check /var/log/mediatomb.log for errors if it fails to start.

     
  • M
    M
    2011-03-22

    Thank you I have made all changes as noted but restarting yields this error:

    2011-03-21 21:51:40    INFO: Loading configuration from: /etc/mediatomb/config.xml
    2011-03-21 21:51:40    INFO: UUID generated: 407fe651-6124-409a-b59d-c7b070680554
    2011-03-21 21:51:40    INFO: Checking configuration...
    2011-03-21 21:51:40   ERROR: Config version "2" does not yet exist!
    
     
  • BT
    BT
    2011-03-22

    Sorry that must of slipped in when I merged it with my 0.12.1 config.xml. Try this one: http://pastebin.com/9fY5nBQT

     
  • M
    M
    2011-03-22

    One more question … to start mediatomb as a service at boot can I use System>Preferences>Start Up Applications in Ubuntu 10.04 and use the command $ mediatomb -d

    See my attached image??

     
  • BT
    BT
    2011-03-22

    I don't know if that will start MediaTomb as a service at boot or start MediaTomb when you log in, which you don't want.
    Since I don't use Ubuntu or GNOME I can't say for sure.

    I do know that MediaTomb should be automatically set to start at boot when installed on Ubuntu. You can check by opening /etc/default/mediatomb and making sure that you have NO_START="no". The reason why it didn't start at boot before is because of the errors you had in your config.xml.

     
  • M
    M
    2011-03-22

    All is well and everything is running smoothly now - thank you amak79!

    To start mediatomb at boot I followed your post above but it failed to start mediatomb at boot.

    I checked the support page http://mediatomb.cc/pages/download and a minor difference is to change the line in /etc/default/mediatomb to read:

    NO_START=""
    

    Now I can watch my computer's video files on my TV!
    Thank you.

     
  • BT
    BT
    2011-03-22

    No problem, glad you got it working.

     
  • mutex
    mutex
    2011-06-12

    The pastebin contents got deleted meanwhile. Can one of you please post the working config file directly?

    Thanks in advance.

     
  • M
    M
    2011-06-12

    No problem, here is the file - I hope it pastes OK.

     <?xml version="1.0" encoding="UTF-8"?>
    <config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd">
      <!--
         Read /usr/share/doc/mediatomb-common/README.gz section 6 for more
         information on creating and using config.xml configration files.
        -->
      <server>
        <ui enabled="yes" show-tooltips="yes">
          <accounts enabled="no" session-timeout="30">
            <account user="mediatomb" password="mediatomb"/>
          </accounts>
        </ui>
        <name>MediaTomb</name>
        <udn>uuid:688fca89-0544-47f5-8347-d88d734aa823</udn>
        <home>/var/lib/mediatomb</home>
        <webroot>/usr/share/mediatomb/web</webroot>
        <storage>
          <sqlite3 enabled="yes">
            <database-file>mediatomb.db</database-file>
          </sqlite3>
          <mysql enabled="no">
            <host>localhost</host>
            <username>mediatomb</username>
            <database>mediatomb</database>
          </mysql>
        </storage>
        <protocolInfo extend="yes"/><!-- For PS3 support change to "yes" -->
        <custom-http-headers>
          <add header="transferMode.dlna.org: Streaming"/>
          <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000"/>
        </custom-http-headers>
        <!--
           Uncomment the lines below to get rid of jerky avi playback on the
           DSM320 or to enable subtitles support on the DSM units
        -->
        <!--
        <custom-http-headers>
          <add header="X-User-Agent: redsonic"/>
        </custom-http-headers>
        <manufacturerURL>redsonic.com</manufacturerURL>
        <modelNumber>105</modelNumber>
        -->
        <!-- Uncomment the line below if you have a Telegent TG100 -->
        <!--
           <upnp-string-limit>101</upnp-string-limit>
        -->
        <extended-runtime-options>
          <ffmpegthumbnailer enabled="yes">
            <thumbnail-size>128</thumbnail-size>
            <seek-percentage>5</seek-percentage>
            <filmstrip-overlay>yes</filmstrip-overlay>
            <workaround-bugs>no</workaround-bugs>
          </ffmpegthumbnailer>
          <mark-played-items enabled="no" suppress-cds-updates="yes">
            <string mode="prepend">*</string>
          </mark-played-items>
        </extended-runtime-options>
      </server>
      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <common-script>/usr/share/mediatomb/js/common.js</common-script>
          <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
          <virtual-layout type="builtin">
            <import-script>/usr/share/mediatomb/js/import.js</import-script>
            <dvd-script>/usr/share/mediatomb/js/import-dvd.js</dvd-script>
          </virtual-layout>
        </scripting>
        <mappings>
          <extension-mimetype ignore-unknown="no">
            <map from="mp3" to="audio/mpeg"/>
            <map from="ogg" to="application/ogg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="m3u" to="audio/x-mpegurl"/>
            <map from="pls" to="audio/x-scpls"/>
            <map from="flv" to="video/x-flv"/>
            <map from="mkv" to="video/mpeg"/>
            <map from="mka" to="audio/x-matroska"/>
            <!-- Uncomment the line below for PS3 divx support -->
            <!-- <map from="avi" to="video/divx"/> -->
            <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
            <!-- <map from="avi" to="video/avi"/> -->
          </extension-mimetype>
          <mimetype-upnpclass>
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
            <map from="application/ogg" to="object.item.audioItem.musicTrack"/>
          </mimetype-upnpclass>
          <mimetype-contenttype>
            <treat mimetype="audio/mpeg" as="mp3"/>
            <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="audio/L16" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
            <treat mimetype="video/mp4" as="mp4"/>
            <treat mimetype="audio/mp4" as="mp4"/>
            <treat mimetype="application/x-iso9660" as="dvd"/>
            <treat mimetype="application/x-iso9660-image" as="dvd"/>
            <treat mimetype="video/x-matroska" as="mkv"/>
            <treat mimetype="audio/x-matroska" as="mka"/>
          </mimetype-contenttype>
        </mappings>
        <online-content>
          <!-- Make sure to setup a transcoding profile for flv -->
          <YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude" format="flv" hd="no">
            <favorites user="mediatomb"/>
            <standardfeed feed="most_viewed" time-range="today"/>
            <playlists user="mediatomb"/>
            <uploads user="mediatomb"/>
            <standardfeed feed="recently_featured" time-range="today"/>
          </YouTube>
          <Weborama enabled="no" refresh="28800" update-at-start="no">
            <playlist name="Active" type="playlist" mood="active"/>
            <playlist name="Metal" type="playlist">
              <filter>
                <genres>metal</genres>
              </filter>
            </playlist>
          </Weborama>
          <AppleTrailers enabled="no" refresh="43200" update-at-start="no" resolution="640"/>
        </online-content>
      </import>
      <transcoding enabled="no">
        <mimetype-profile-mappings>
          <transcode mimetype="video/x-flv" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
        </mimetype-profile-mappings>
        <profiles>
          <profile name="oggflac2raw" enabled="no" type="external">
            <mimetype>audio/L16</mimetype>
            <accept-url>no</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          </profile>
          <profile name="vlcmpeg" enabled="no" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>yes</accept-ogg-theora>
            <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
          </profile>
        </profiles>
      </transcoding>
    </config>
    
     
  • David Buzinkai
    David Buzinkai
    2011-08-04

    Hi guys, I just found this discussion and I will be really happy if someone can help me here.
    I have a very similar issue but not the same:
    - I have Samsung LE46D570
    - Ubuntu Server edition 10.04
    - Installed Mediatomb version 0.12.1

    Nothing was working at beginning but after a while i got successfully working videos (with pause, ffw, …) and pictures
    but im not able to get work MP3s correctly. TV says: "Not Supported File Format" and tries to play other file in row and so …
    Then when it comes to 10th file it will play it without any problems and all next files in row too.\
    I have tried with different files under different folders and it always starts playing a 10th file no matter what file it is (and with previous 9 files it fails). When i stop playing and try to play previously played file it again fails 9 times and start working since 10th file in row.

    logfile says:

    2011-08-04 13:37:55   ERROR: ActionRequest::update(): response is nil, code -115
    2011-08-04 13:37:55   ERROR: ActionRequest::update(): response is nil, code -115
    2011-08-04 13:37:55   ERROR: ActionRequest::update(): response is nil, code -115
    2011-08-04 13:37:55   ERROR: ActionRequest::update(): response is nil, code -115
    2011-08-04 13:37:59   ERROR: ActionRequest::update(): response is nil, code -115
    2011-08-04 13:37:59   ERROR: ActionRequest::update(): response is nil, code -115
    2011-08-04 13:37:59   ERROR: ActionRequest::update(): response is nil, code -115
    2011-08-04 13:37:59   ERROR: ActionRequest::update(): response is nil, code -115
    2011-08-04 13:38:00   ERROR: ActionRequest::update(): response is nil, code -115
    2011-08-04 13:38:03   ERROR: ActionRequest::update(): response is nil, code -115
    2011-08-04 13:38:08   ERROR: ActionRequest::update(): response is nil, code -115
    2011-08-04 13:38:22   ERROR: Object not found: 98043
    2011-08-04 13:38:26   ERROR: Object not found: 98082
    2011-08-04 13:38:29   ERROR: Object not found: 98079
    2011-08-04 13:38:32   ERROR: Object not found: 98049
    2011-08-04 13:38:35   ERROR: Object not found: 98052
    2011-08-04 13:38:39   ERROR: Object not found: 98055
    2011-08-04 13:38:42   ERROR: Object not found: 98058
    2011-08-04 13:38:45   ERROR: Object not found: 98061
    2011-08-04 13:38:48   ERROR: Object not found: 98064
    

    my comlete config.xml file:

    <?xml version="1.0" encoding="UTF-8"?>
    <config version="2" xmlns="http://mediatomb.cc/config/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/2 http://mediatomb.cc/config/2.xsd">
      <server>
        <name>MediaTomb</name>
        <port>49152</port>
        <udn>uuid:0964b055-aa73-4cab-80df-cf49dc01b549</udn>
        <home>/home/mediatomb</home>
        <webroot>/usr/local/share/mediatomb/web</webroot>
        <pc-directory upnp-hide="yes"/>
        <items-per-page default="100"/>
        <ui enabled="yes" show-tooltips="yes">
          <accounts enabled="yes" session-timeout="30">
            <account user="admin" password="[p[p1212"/>
          </accounts>
        </ui>
        <storage>
          <mysql enabled="yes">
            <host>localhost</host>
            <username>mediatomb</username>
            <password>popo1212</password>
            <database>mediatomb</database>
          </mysql>
        </storage>
        <protocolInfo extend="yes"/>
        <custom-http-headers>
          <!-- <add header="X-User-Agent: redsonic"/> -->
          <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01700000000000000000000000000000"/>
        </custom-http-headers>
        <manufacturerURL>redsonic.com</manufacturerURL>
        <modelNumber>105</modelNumber>
        <!-- Uncomment the line below if you have a Telegent TG100 -->
        <!--
           <upnp-string-limit>101</upnp-string-limit>
        -->
        <extended-runtime-options>
          <ffmpegthumbnailer enabled="yes">
            <thumbnail-size>128</thumbnail-size>
            <seek-percentage>5</seek-percentage>
            <filmstrip-overlay>yes</filmstrip-overlay>
            <workaround-bugs>no</workaround-bugs>
            <image-quality>8</image-quality>
          </ffmpegthumbnailer>
          <mark-played-items enabled="no" suppress-cds-updates="yes">
            <string mode="prepend">*</string>
            <mark>
              <content>video</content>
            </mark>
          </mark-played-items>
        </extended-runtime-options>
      </server>
      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <common-script>/usr/local/share/mediatomb/js/common.js</common-script>
          <playlist-script>/usr/local/share/mediatomb/js/playlists.js</playlist-script>
          <virtual-layout type="js">
            <import-script>/usr/local/share/mediatomb/js/import.js</import-script>
          </virtual-layout>
        </scripting>
        <autoscan use-inotify="auto">
            <directory location="/mnt/disk1/music" mode="inotify" recursive="yes"/>
            <directory location="/mnt/disk1/pictures" mode="inotify" recursive="yes"/>
            <directory location="/mnt/disk2/videos" mode="inotify" recursive="yes"/>
        </autoscan>
        <mappings>
          <extension-mimetype ignore-unknown="no">
            <map from="mp3" to="audio/mpeg"/>
            <map from="ogx" to="application/ogg"/>
            <map from="ogv" to="video/ogg"/>
            <map from="oga" to="audio/ogg"/>
            <map from="ogg" to="audio/ogg"/>
            <map from="ogm" to="video/ogg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="m3u" to="audio/x-mpegurl"/>
            <map from="pls" to="audio/x-scpls"/>
            <map from="flv" to="video/x-flv"/>
            <map from="mkv" to="video/mpeg"/>
            <map from="mka" to="audio/x-matroska"/>
            <!-- Uncomment the line below for PS3 divx support -->
            <!-- <map from="avi" to="video/divx"/> -->
            <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
            <!-- <map from="avi" to="video/avi"/> -->
          </extension-mimetype>
          <mimetype-upnpclass>
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
          </mimetype-upnpclass>
          <mimetype-contenttype>
            <treat mimetype="audio/mpeg" as="mp3"/>
            <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="audio/L16" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
            <treat mimetype="video/mp4" as="mp4"/>
            <treat mimetype="audio/mp4" as="mp4"/>
            <treat mimetype="application/x-iso9660" as="dvd"/>
            <treat mimetype="application/x-iso9660-image" as="dvd"/>
          </mimetype-contenttype>
        </mappings>
      </import>
      <transcoding enabled="no">
        <mimetype-profile-mappings>
          <transcode mimetype="video/x-flv" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
        </mimetype-profile-mappings>
        <profiles>
          <profile name="oggflac2raw" enabled="no" type="external">
            <mimetype>audio/L16</mimetype>
            <accept-url>no</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          </profile>
          <profile name="vlcmpeg" enabled="no" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>yes</accept-ogg-theora>
            <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
          </profile>
        </profiles>
      </transcoding>
    </config>
    

    I would really appreciate if somebody can help here.

    PS: with Samsungs Allshare software, with Twonky or through USB the files are played just fine without any issues so Im pretty sure that rootcause is in some mediathomb's setting or binary.

    Thanks,
    David

     
  • Justin Buser
    Justin Buser
    2012-10-16

    The relevant changes to the config file seem to be:

    <custom-http-headers>
          <add header="transferMode.dlna.org: Streaming"/>
          <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000"/>
        </custom-http-headers>

    Adding that information (make sure it's not commented / i.e. surrounded with <!-  -> ) resolved this problem for me.

     

  • Anonymous
    2012-11-22

    @buservt, thanks for posting the relevant changes. I had the same problem… after adding the custom-http-headers as shown above, it works great now on my Samsung TV!