Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Subtitle Transcoding to LG BD390

Help
2009-09-10
2013-05-30
  • Casey Hunter
    Casey Hunter
    2009-09-10

    I have done the subtitle piggybacking method detailed in the Wiki but am having troubles.  the FIFO pipe that it creates only exists for a few seconds before changing(i.e. mt_transcode_GPZPZU becomes mt_transcode_AYCSZU, followed by mt_transcode_R27VZU and so on)   .  It seems as if  <agent command="/usr/local/bin/mediatomb-mencoder-srt" arguments="%in %out"/>
    keeps getting called over and over again.   Is my BD390 repeatedly restarting the transcode?  Or is Mediatomb or Ubuntu 8.04 at fault.

    My Setup:
    MediaTomb UPnP Server version 0.12.0
    LG BD390 Blu-ray player
    Ubuntu 8.04 (hardy heron)

    Thanks for any help.

     
  • Ginsengelf
    Ginsengelf
    2011-09-24

    Hi, I know I'm exhuming an old thread, but I have the same problem:

    I'm running mediatomb 0.12.1 on openSUSE11.4, 64bit.
    When I try to play a .mkv file using my LG BD390 Player, my transcoding script starts and quits after roughly a second, starts again, quits, … without end.
    I'm using the config and transcoding script from here: http://forums.gentoo.org/viewtopic-t-888472-start-12.html
    When I start the transcoding script from the command line everything is fine.

    Any ideas?

    Thanks in advance,

    Ginsengelf

     
  • Kyle
    Kyle
    2011-12-02

    I'm having the same problem with my LG BD670. I think it's a bug with LG since at other places I've seen people report the same problem.

     
  • Kyle
    Kyle
    2011-12-13

    Looking at it some more over the past few days, LG's setup is a really mess and probably needs to be fixed by LG. The xml files generated by the device are a mess with extra junk at the end causing problems with some servers that expect a pure xml file, mediatomb can handle it, but another upnp server I tried sees it as junk and doesn't properly identify it as LG. They completely ignore the first-resource flag system. i.e. With an flv file instead of just accepting the transcoded output, it just reads it as flv and says unsupporte, so with files that are unsupported you need to add the hide-original-resource flag to the profile. However that doesn't fix the flood of transcoding attempts, I'm guessing it might have to do with how LG just takes all the contents of the folder as a playlist, and when it can't get the entire file right away since the transcoding process is on the fly, it keeps trying over and over until it gives up.