MediaTomb as a server for DLNA TVs Sony KDL?

Help
Sergey
2011-07-22
2013-05-30
  • Sergey
    Sergey
    2011-07-22

    There are TVs Sony Bravia KDL-… and Popcorn C-200. MediaTomb set on the C-200.

    TVs support protocol DLNA.

    MediaTomb launched successfully. Via WEB interface pointed to the path to scan HDD drive in the C-200. Successfully.

    On TVs launched through the diagnostics menu Servers. TVs found MediaTomb, but counted as unsuccessful attempts.
    That is what is written in the detailed diagnostic data TVs:

    The server is not supported.
    Server: MediaTomb
    UPN: uuid: 9d803a4-…
    Address MAC: 00:06: dc: 81: e5: c7
    Port TCP: 49152
    The server does not support them.

    What can I do?
    Or is it unavoidably?


    I write later … confused

    After adding /modifying lines in the config.xml (adapted from an article at: MediaTomb config for Linux):

        Quote:<protocolInfo extend="yes"/>
        <custom-http-headers>
        <add header="transferMode.dlna.org: Streaming"/>
        <add header="contentFeatures.dlna.org:DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000"/>
        </custom-http-headers>

    and

        Quote:<mappings>
        <extension-mimetype ignore-unknown="no">
        <map from="mp3" to="audio/mpeg"/>
        <map from="ogg" to="application/ogg"/>
        <map from="asf" to="video/x-ms-asf"/>
        <map from="asx" to="video/x-ms-asf"/>
        <map from="wma" to="audio/x-ms-wma"/>
        <map from="wax" to="audio/x-ms-wax"/>
        <map from="wmv" to="video/x-ms-wmv"/>
        <map from="wvx" to="video/x-ms-wvx"/>
        <map from="wm" to="video/x-ms-wm"/>
        <map from="wmx" to="video/x-ms-wmx"/>
        <map from="m3u" to="audio/x-mpegurl"/>
        <map from="pls" to="audio/x-scpls"/>
        <map from="ts" to="video/mpeg"/>
        <map from="m2ts" to="video/mpeg"/>
        <map from="vob" to="video/mpeg"/>
        <map from="wav" to="audio/wav"/>
        <map from="mpg" to="video/mpeg"/>
        <map from="aac" to="audio/x-aac"/>
        <map from="m4a" to="audio/mp4"/>
        <map from="mkv" to="video/x-matroska"/>
        <map from="mov" to="video/x-quicktime"/>
        <map from="flv" to="video/x-flv"/>
        <map from="divx" to="video/divx"/>
        <map from="avi" to="video/x-msvideo"/>
        </extension-mimetype>

    Now, after the diagnosis of TV servers write:

    Could not find supported files.
    Server: MediaTomb
    UPN: uuid: 9d803a4-…
    Address MAC: 00:06: dc: 81: e5: c7
    Port TCP: 49152

    So all is not lost and can be used in MediaTomb as a server running on the protocol for DLNA TVs Sony Bravia KDL-…?

     

  • Anonymous
    2011-12-07

    The same story with my Sony Bravia KDL-46W5500

    My mediatomb is hosted on a linuxbox and works well for other clients

    I wonder if there is a solution

     

  • Anonymous
    2011-12-20

    You need patch from https://sourceforge.net/projects/mediatomb/forums/forum/440751/topic/2748463/index/page/2

    and

          <profile name="video2mpeg" enabled="yes" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <agent command="ffmpeg" arguments="-i %in -c:v mpeg2video -b 12288k -threads 4 -c:a ac3 -ab 384k -f dvd -y %out"/>
            <buffer size="10485760" chunk-size="131072" fill-size="2621440"/>
          </profile>

    Unfortunately rewind still is not working

     
  • prioryjim
    prioryjim
    2012-07-30

    I have a Sony KDL40W5500U
    I have made a mpg file and want to play it on the Sony via DLNA
    minidlna will play this Video OK.
    But I wanted mediatomb ( for transcoding eventually)
    Originally the Sony reported "The server is not supported."
    But adding some details from above posts I now get "Could not find supported files."
    But they play via minidlna ??
    Is there something I need to get mediatomb to play the mpg ( without transcoding ).
    Hopefully I can then work on transcoding.
    Thanks
    Jim