Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Help me pls.. Config.xml for Toshiba Regza

Help
kuld
2011-01-24
2013-05-30
  • kuld
    kuld
    2011-01-24

    anybody help please!
    during 3 week I try to configure mediatomb with Toshiba Regza 40XL433
    TV connecting to server, playing mp3, show fotos, but don`t play any movies.
    On user manual for this TV has wrote support:

    Video: MPEG2(PS) PAL, MPEG2(PS) NTSC, MPEG2(TS)
    Audio: LPCM / MPEG1-Layer1 / MPEG1-Layer2 / MPEG2- Layer2 / Dolby Digital (AC-3)

    Dont playing files on this codec, dont playing transcoded stream :(
    Anybody who did it… give me please config.xml.

     

  • Anonymous
    2011-02-05

    Hey kuldrus,

    I am trying to run mediatomb with a Toshiba Regza 37XV733. Maybe I could give you a hand when you tell me how you configured your config.xml looks like? I think together we could work it out.

    By the way: What operating system is your mediatomb running on?

    Regards
    dirtyhawk

     
  • kuld
    kuld
    2011-03-26

    Hi!
    I running it on Ubuntu 10.10
    Linux Core 2.6.35-28-generic

    config.xml

    <?xml version="1.0" encoding="UTF-8"?>
    <config version="2" xmlns="http://mediatomb.cc/config/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/2 http://mediatomb.cc/config/2.xsd"><!--
         Read /usr/share/doc/mediatomb-common/README.gz section 6 for more
         information on creating and using config.xml configration files.
        -->
      <server>
        <ui enabled="yes" show-tooltips="yes">
          <accounts enabled="no" session-timeout="30">
            <account user="mediatomb" password="mediatomb"/>
          </accounts>
        </ui>
        <!--<ip>192.168.1.2</ip>-->
        <port>49152</port>
        <name>KULDBUNTU MediaTomb</name>
        <udn>uuid:5b0fd976-28b2-49cd-9502-3d6d44fac54d</udn>
        <home>/home/kuld/.mediatomb</home>
        <webroot>/usr/share/mediatomb/web</webroot>
        <storage caching="yes">
          <sqlite3 enabled="yes">
            <database-file>mediatomb.db</database-file>
          </sqlite3>
          <mysql enabled="no">
            <host>localhost</host>
            <username>mediatomb</username>
            <database>mediatomb</database>
          </mysql>
        </storage>
        <protocolInfo extend="yes"/><!-- For PS3 support change to "yes" --><!--
           Uncomment the lines below to get rid of jerky avi playback on the
           DSM320 or to enable subtitles support on the DSM units
        --><!--
        <custom-http-headers>
          <add header="X-User-Agent: redsonic"/>
        </custom-http-headers>
        <manufacturerURL>redsonic.com</manufacturerURL>
        <modelNumber>105</modelNumber>
        --><!-- Uncomment the line below if you have a Telegent TG100 --><!--
           <upnp-string-limit>101</upnp-string-limit>
        -->
        <custom-http-headers>
        <add header="transferMode.dlna.org: Streaming"/>
        <add header="contentFeatures.dlna.org:DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01500000000000000000000000000000"/>
        </custom-http-headers>
        <pc-directory upnp-hide="no"/>
        <extended-runtime-options>
          <ffmpegthumbnailer enabled="yes">
            <thumbnail-size>128</thumbnail-size>
            <seek-percentage>5</seek-percentage>
            <filmstrip-overlay>yes</filmstrip-overlay>
            <workaround-bugs>no</workaround-bugs>
          </ffmpegthumbnailer>
          <mark-played-items enabled="no" suppress-cds-updates="yes">
            <string mode="prepend">*</string>
          </mark-played-items>
        </extended-runtime-options>
      </server>
      <filesystem-charset>UTF-8</filesystem-charset>
      <metadata-charset>UTF-8</metadata-charset>
      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <common-script>/usr/share/mediatomb/js/common.js</common-script>
          <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
          <virtual-layout type="builtin">
            <import-script>/usr/share/mediatomb/js/import.js</import-script>
            <dvd-script>/usr/share/mediatomb/js/import-dvd.js</dvd-script>
          </virtual-layout>
        </scripting>
        <mappings>
      <extension-mimetype ignore-unknown="no" case-sensitive="no">
        <map from="mp3" to="audio/mpeg"/>
        <map from="ogg" to="application/ogg"/>
        <map from="asf" to="video/x-ms-asf"/>
        <map from="asx" to="video/x-ms-asf"/>
        <map from="wma" to="audio/x-ms-wma"/>
        <map from="wax" to="audio/x-ms-wax"/>
        <map from="wmv" to="video/x-ms-wmv"/>
        <map from="wvx" to="video/x-ms-wvx"/>
        <map from="wm" to="video/x-ms-wm"/>
        <map from="wmx" to="video/x-ms-wmx"/>
        <map from="m3u" to="audio/x-mpegurl"/>
        <map from="pls" to="audio/x-scpls"/>
        <map from="ts" to="video/mpeg"/>
        <map from="ps" to="video/mpeg"/>
        <map from="m2ts" to="video/mpeg"/>
        <map from="vob" to="video/mpeg"/>
        <map from="wav" to="audio/wav"/>
        <map from="mpg" to="video/mpeg"/>
        <map from="m2v" to="video/mpeg"/>
        <map from="aac" to="audio/x-aac"/>
        <map from="m4a" to="audio/mp4"/>
        <map from="mkv" to="video/x-matroska"/>
        <map from="mov" to="video/x-quicktime"/>
        <map from="flv" to="video/x-flv"/>
        <map from="divx" to="video/divx"/>
        <map from="xvid" to="video/divx"/>
        <map from="avi" to="video/x-msvideo"/>
        <!--<map from="avi" to="video/divx"/>-->
      </extension-mimetype>
          <mimetype-upnpclass>
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
            <map from="application/ogg" to="object.item.audioItem.musicTrack"/>
          </mimetype-upnpclass>
          <mimetype-contenttype>
          <treat mimetype="audio/mpeg" as="mp3"/>
            <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
            <treat mimetype="audio/vt-wav" as="wav"/>
           </mimetype-contenttype> 
        </mappings>
      </import>
      <transcoding enabled="yes">
      <mimetype-profile-mappings> 
       <transcode mimetype="video/x-flv" using="vlcmpeg"/> 
       <transcode mimetype="video/x-msvideo" using="vlcmpeg"/> 
       <transcode mimetype="application/ogg" using="vlcmpeg"/>
       <transcode mimetype="video/x-matroska" using="vlcmpeg"/>
       <transcode mimetype="application/ogg" using="oggflac2raw"/> 
       <transcode mimetype="audio/x-flac" using="oggflac2raw"/> 
      </mimetype-profile-mappings> 
      <profiles> 
       <profile name="oggflac2raw" enabled="no" type="external"> 
       <mimetype>audio/L16</mimetype> 
       <accept-url>no</accept-url> 
       <first-resource>yes</first-resource> 
       <accept-ogg-theora>no</accept-ogg-theora> 
       <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/> 
       <buffer size="1048576" chunk-size="131072" fill-size="262144"/> 
      </profile> 
      <profile name="vlcmpeg" enabled="yes" type="external"> 
       <mimetype>video/mpeg</mimetype> 
       <accept-url>yes</accept-url> 
       <first-resource>yes</first-resource> 
       <accept-ogg-theora>yes</accept-ogg-theora> 
       <agent command="vlc" arguments="-I dummy %in --sout
    #transcode{vcodec=mp2v,vb=4096,fps=25,vfilter=canvas{width=720,height=576},acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out}
    vlc:quit"/> 
       <buffer size="14400000" chunk-size="512000" fill-size="120000"/> 
      </profile> 
     </profiles> 
    </transcoding> 
    </config>
    
     
  • kuld
    kuld
    2011-03-27

    more….
    VLC on other PC play video from Mediatomb correctly. I can see that media transcoding in log.
    But when I try to play video form my TV - nothing happened :( 

     
  • kuld
    kuld
    2011-04-27

    up :)

     
  • kuld
    kuld
    2011-08-04

    up………….