Trouble installing

Help
2011-01-08
2013-05-30
  • Anders Olesen
    Anders Olesen
    2011-01-08

    Hi

    I am using Ubuntu Lucid
    I have tried to install both version 0.12 and the latest svn build.
    ./configure works
    make fails with these messages:

    g/import_script.cc' || echo './'`../src/scripting/import_script.cc
    ../src/scripting/import_script.cc: In constructor ‘ImportScript::ImportScript(zmm::Ref<Runtime>)’:
    ../src/scripting/import_script.cc:57: error: ‘JS_AddNamedRoot’ was not declared in this scope
    ../src/scripting/import_script.cc: In destructor ‘virtual ImportScript::~ImportScript()’:
    ../src/scripting/import_script.cc:120: error: ‘JS_RemoveRoot’ was not declared in this scope
    make[2]: *** [libmediatomb_a-import_script.o] Fejl 1
    make[2]: Forlader katalog '/home/anders/mediatomb-0.12.1/build'
    make[1]: *** [all-recursive] Fejl 1
    make[1]: Forlader katalog '/home/anders/mediatomb-0.12.1'
    make: *** [all] Fejl 2
    

    I do not understand what is happening here. Is someone able to help me?

    Thanks…

     
  • James Cooksey
    James Cooksey
    2011-03-11

    I am facing the exact problem as above. Running Ubuntu Lucid and now Maverick. Any advice greatly appreciated!