Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Can't see Mediatomb server

Help
2011-04-10
2013-05-30
  • Sir_Daniel23
    Sir_Daniel23
    2011-04-10

    Hi,

    i have installed mediatomb on an ubuntu 10.10 server without any problems and added music to the database via the webinterface. Everything seems to run fine - there are no errors in the logfile.

    Unfortunately mediatomb doesn't show up in the windows network places and no upnp client (e.g xbmc) can find it except foobar with upnp plugin.
    I tried all steps from the mediatomb FAQ with no luck.

    Later i installed mediatomb on a virtual machine - also on ubuntu 10.10 server - and i could see it right away in the network places under windows 7. Both, the mediatomb on the virtual machine, and the real server have the same config - i don't know why the 'real' server doesn't show up. The network setup is fine. I also reinstalled ubuntu several times.

    Now i'm out of ideas - do you have any that could fix my problem?

    Kind regards,
    Daniel

     
  • Carter Bronson
    Carter Bronson
    2011-08-15

    I am having a very similar problem, and would appreciate any help…

    I am running Debian 6.0 Stable, and installed Mediatomb through APT.  I've made minimal changes to /etc/mediatomb.config.xml, and restarted Mediatomb.  I added a few songs to the database using the web UI (which I enabled in the config.xml).  Everything seems to be running fine; Mediatomb log is clean, and here's the output of ps aux | grep mediatomb:

    111       7876  0.0  0.3 224448  6224 ?        Ssl  22:37   0:00 /usr/bin/mediatomb -c /etc/mediatomb/config.xml -d -u mediatomb -g mediatomb -P /var/run/mediatomb.pid -l /var/log/mediatomb.log
    

    Unfortunately, nothing I've tried can actually detect the uPnP server.  I enabled uPnP support on VLC on localhost, and it can't detect it.  I've also tried to detect it over the LAN with my PS3 and UPnPlay on my Android Phone (connected to LAN via wifi).  None of them see the server.

    I've played around with my firewall settings both on the Debian box and my router.  Traffic over port 1900 and 49152 are allowed on both, and I permitted multicast on the router. 

    I have a feeling this has to be something very basic that I've missed, and I will feel very stupid when somebody tells me what it is.  So please, let me know what I'm missing so I can feel stupid, and then fix it and have a working Mediatomb server.

    I'm including the contents of /var/log/mediatomb.log and /etc/mediatomb/config.xml below.  The only changes I made to the default config.xml were:
    1) Enable web UI
    2) Set port to 49152 and interface to eth0
    3) Enable PS3
    4) Enable PS3 .avi support

    2011-08-14 22:37:20    INFO: Loading configuration from: /etc/mediatomb/config.xml
    2011-08-14 22:37:20    INFO: UUID generated: e789bca0-2603-4dc5-9c8c-b56c7a7396f5
    2011-08-14 22:37:20    INFO: Checking configuration...
    2011-08-14 22:37:20    INFO: Setting filesystem import charset to UTF-8
    2011-08-14 22:37:20    INFO: Setting metadata import charset to UTF-8
    2011-08-14 22:37:20    INFO: Setting playlist charset to UTF-8
    2011-08-14 22:37:20    INFO: Configuration check succeeded.
    2011-08-14 22:37:20 WARNING: Sqlite3 database seems to be corrupt or doesn't exist yet.
    2011-08-14 22:37:20    INFO: no sqlite3 backup is available or backup is corrupt. automatically creating database...
    2011-08-14 22:37:20    INFO: database created successfully.
    2011-08-14 22:37:20    INFO: Initialized port: 49152
    2011-08-14 22:37:20    INFO: Server bound to: 192.168.1.103
    2011-08-14 22:37:21    INFO: MediaTomb Web UI can be reached by following this link:
    2011-08-14 22:37:21    INFO: http://192.168.1.103:49152/
    2011-08-14 22:39:51    INFO: MediaTomb shutting down. Please wait...
    2011-08-14 22:39:52    INFO: Server terminating
    2011-08-14 22:39:53    INFO: Loading configuration from: /etc/mediatomb/config.xml
    2011-08-14 22:39:53    INFO: Checking configuration...
    2011-08-14 22:39:53    INFO: Setting filesystem import charset to UTF-8
    2011-08-14 22:39:53    INFO: Setting metadata import charset to UTF-8
    2011-08-14 22:39:53    INFO: Setting playlist charset to UTF-8
    2011-08-14 22:39:53    INFO: Configuration check succeeded.
    2011-08-14 22:39:53    INFO: Initialized port: 49152
    2011-08-14 22:39:53    INFO: Server bound to: 192.168.1.103
    2011-08-14 22:39:54    INFO: MediaTomb Web UI can be reached by following this link:
    2011-08-14 22:39:54    INFO: http://192.168.1.103:49152/
    2011-08-14 22:41:14    INFO: MediaTomb shutting down. Please wait...
    2011-08-14 22:41:15    INFO: Server terminating
    2011-08-14 22:41:16    INFO: Loading configuration from: /etc/mediatomb/config.xml
    2011-08-14 22:41:16    INFO: Checking configuration...
    2011-08-14 22:41:16    INFO: Setting filesystem import charset to UTF-8
    2011-08-14 22:41:16    INFO: Setting metadata import charset to UTF-8
    2011-08-14 22:41:16    INFO: Setting playlist charset to UTF-8
    2011-08-14 22:41:16    INFO: Configuration check succeeded.
    2011-08-14 22:41:16    INFO: Initialized port: 49152
    2011-08-14 22:41:16    INFO: Server bound to: 192.168.1.103
    2011-08-14 22:41:17    INFO: MediaTomb Web UI can be reached by following this link:
    2011-08-14 22:41:17    INFO: http://192.168.1.103:49152/
    
    <?xml version="1.0" encoding="UTF-8"?>
    <config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd">
      <!--
         Read /usr/share/doc/mediatomb-common/README.gz section 6 for more
         information on creating and using config.xml configration files.
        -->
      <server>
        <ui enabled="yes" show-tooltips="yes">
          <accounts enabled="no" session-timeout="30">
            <account user="mediatomb" password="mediatomb"/>
          </accounts>
        </ui>
        <name>MediaTomb</name>
        <port>49152</port>
        <interface>eth0</interface>
        <udn>uuid:e789bca0-2603-4dc5-9c8c-b56c7a7396f5</udn>
        <home>/var/lib/mediatomb</home>
        <webroot>/usr/share/mediatomb/web</webroot>
        <storage>
          <sqlite3 enabled="yes">
            <database-file>mediatomb.db</database-file>
          </sqlite3>
          <mysql enabled="no">
            <host>localhost</host>
            <username>mediatomb</username>
            <database>mediatomb</database>
          </mysql>
        </storage>
        <protocolInfo extend="yes"/><!-- For PS3 support change to "yes" -->
        <!--
           Uncomment the lines below to get rid of jerky avi playback on the
           DSM320 or to enable subtitles support on the DSM units
        -->
        <!--
        <custom-http-headers>
          <add header="X-User-Agent: redsonic"/>
        </custom-http-headers>
        <manufacturerURL>redsonic.com</manufacturerURL>
        <modelNumber>105</modelNumber>
        -->
        <!-- Uncomment the line below if you have a Telegent TG100 -->
        <!--
           <upnp-string-limit>101</upnp-string-limit>
        -->
        <extended-runtime-options>
          <ffmpegthumbnailer enabled="no">
            <thumbnail-size>128</thumbnail-size>
            <seek-percentage>5</seek-percentage>
            <filmstrip-overlay>yes</filmstrip-overlay>
            <workaround-bugs>no</workaround-bugs>
          </ffmpegthumbnailer>
          <mark-played-items enabled="no" suppress-cds-updates="yes">
            <string mode="prepend">*</string>
          </mark-played-items>
        </extended-runtime-options>
      </server>
      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <common-script>/usr/share/mediatomb/js/common.js</common-script>
          <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
          <virtual-layout type="builtin">
            <import-script>/usr/share/mediatomb/js/import.js</import-script>
            <dvd-script>/usr/share/mediatomb/js/import-dvd.js</dvd-script>
          </virtual-layout>
        </scripting>
        <mappings>
          <extension-mimetype ignore-unknown="no">
            <map from="mp3" to="audio/mpeg"/>
            <map from="ogg" to="application/ogg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="m3u" to="audio/x-mpegurl"/>
            <map from="pls" to="audio/x-scpls"/>
            <map from="flv" to="video/x-flv"/>
            <map from="mkv" to="video/x-matroska"/>
            <map from="mka" to="audio/x-matroska"/>
            <!-- Uncomment the line below for PS3 divx support -->
            <map from="avi" to="video/divx"/> 
            <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
            <!-- <map from="avi" to="video/avi"/> -->
          </extension-mimetype>
          <mimetype-upnpclass>
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
            <map from="application/ogg" to="object.item.audioItem.musicTrack"/>
          </mimetype-upnpclass>
          <mimetype-contenttype>
            <treat mimetype="audio/mpeg" as="mp3"/>
            <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="audio/L16" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
            <treat mimetype="video/mp4" as="mp4"/>
            <treat mimetype="audio/mp4" as="mp4"/>
            <treat mimetype="application/x-iso9660" as="dvd"/>
            <treat mimetype="application/x-iso9660-image" as="dvd"/>
            <treat mimetype="video/x-matroska" as="mkv"/>
            <treat mimetype="audio/x-matroska" as="mka"/>
          </mimetype-contenttype>
        </mappings>
        <online-content>
          <!-- Make sure to setup a transcoding profile for flv -->
          <YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude" format="flv" hd="no">
            <favorites user="mediatomb"/>
            <standardfeed feed="most_viewed" time-range="today"/>
            <playlists user="mediatomb"/>
            <uploads user="mediatomb"/>
            <standardfeed feed="recently_featured" time-range="today"/>
          </YouTube>
          <Weborama enabled="no" refresh="28800" update-at-start="no">
            <playlist name="Active" type="playlist" mood="active"/>
            <playlist name="Metal" type="playlist">
              <filter>
                <genres>metal</genres>
              </filter>
            </playlist>
          </Weborama>
          <AppleTrailers enabled="no" refresh="43200" update-at-start="no" resolution="640"/>
        </online-content>
      </import>
      <transcoding enabled="no">
        <mimetype-profile-mappings>
          <transcode mimetype="video/x-flv" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
        </mimetype-profile-mappings>
        <profiles>
          <profile name="oggflac2raw" enabled="no" type="external">
            <mimetype>audio/L16</mimetype>
            <accept-url>no</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          </profile>
          <profile name="vlcmpeg" enabled="no" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>yes</accept-ogg-theora>
            <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
          </profile>
        </profiles>
      </transcoding>
    </config>
    
     
  • appy
    appy
    2011-08-28

    I wonder if the problem you're having relates at all to a mediatomb visibility problem I'm having. As per the following thread it seems that whenever I have a Win 7 server booted I lose visibility of my mediatomb server on Debian 5 accessed via a DD-WRT router.

    http://www.dd-wrt.com/phpBB2/viewtopic.php?p=632390#632390

     
  • gbossicard
    gbossicard
    2013-03-03

    I know it's necroposting but I found a solution to my similar problem. I just disabled the SSDP Discovery service on the Windows machine.