I have Centos 6.2 running the following mediatomb version

MediaTomb UPnP Server version 0.12.1 - http://mediatomb.cc/

===============================================================================
Copyright 2005-2010 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
MediaTomb is free software, covered by the GNU General Public License version 2

Compile info:

host: x86_64-unknown-linux-gnu
sqlite3: yes
mysql: yes
libjs: yes
libmagic: yes
inotify: yes
libexif: yes
id3lib: disabled
taglib: yes
ffmpeg yes
libmp4v2: yes
external transcoding: yes
curl: yes
YouTube: yes
libextractor disabled
db-autocreate: yes
debug log: yes
protocol info extension:yes
ffmpegthumbnailer: missing
lastfmlib: missing
data directory: /usr/share/mediatomb

I have an issue with the autorefresh options.

I have two directories I wish to share using mediatomb /storage/tv and /storage/movies

If I add these directories without the recursive option enabled I get the layout I require

Video
-Directories
-tv
--tv.show01
---season01
---s01e01.avi
---s01e02.avi
---season02
---s02e01.avi
-movies
--movie1
---movie1.avi
--movie2
---movie2.avi

etc but the autoscaning doesn't work and when a new episode or movie is downloading it does not appear.

So i then read that I should be using the inotify option that required the recursive option enabled like this in the config.xml file

<autoscan use-inotify="auto">
        <directory location="/storage/tv" mode="inotify" recursive="yes" hidden-files="no"/>
        <directory location="/storage/movies" mode="inotify" recursive="yes" hidden-files="no"/>
    </autoscan>

This now seems to detect when new files are added how ever the tree structure is completely shot it looks like this

Video
-Directories
-tv
-tv.show01
-season01
--s01e01.avi
--s01e02.avi
-season02
--s02e01.avi
-movies
-movie1
--movie1.avi
-movie2
--movie2.avi

so all my season01 tv episodes are now dumped in to a season01 folder directly under  Directories all my moves appear under Directories.

I also tried changing <virtual-layout type="builtin"> to <virtual-layout type="js">

Is it possible to get this to work corectly?