Problem with libexim when cross compiling

Help
doragasu
2011-01-15
2013-05-30
  • doragasu
    doragasu
    2011-01-15

    I'm try to cross-compile mediatomb 0.12.1 for arm5te architecture. The problem I have is with libexim library. I tell ./configure the right path to the library headers, but it's not able to find them:

    configure: Will search for libexif headers in /home/doragasu/src/oe/stuff/build/tmp/sysroots/armv5te-angstrom-linux-gnueabi/usr/include
    checking /home/doragasu/src/oe/stuff/build/tmp/sysroots/armv5te-angstrom-linux-gnueabi/usr/include/libexif/exif-content.h usability... no
    checking /home/doragasu/src/oe/stuff/build/tmp/sysroots/armv5te-angstrom-linux-gnueabi/usr/include/libexif/exif-content.h presence... no
    checking for /home/doragasu/src/oe/stuff/build/tmp/sysroots/armv5te-angstrom-linux-gnueabi/usr/include/libexif/exif-content.h... no
    configure: error: libexif headers not found in requested location /home/doragasu/src/oe/stuff/build/tmp/sysroots/armv5te-angstrom-linux-gnueabi/usr/include
    

    The weird thing is the header files are just were ./configure is looking, but it can't find them…

    ls -l /home/doragasu/src/oe/stuff/build/tmp/sysroots/armv5te-angstrom-linux-gnueabi/usr/include/libexif/
    total 92
    -rw-r--r-- 1 doragasu doragasu  1438 2011-01-15 17:40 exif-byte-order.h
    -rw-r--r-- 1 doragasu doragasu  4649 2011-01-15 17:40 exif-content.h
    -rw-r--r-- 1 doragasu doragasu  8738 2011-01-15 17:40 exif-data.h
    -rw-r--r-- 1 doragasu doragasu  1433 2011-01-15 17:40 exif-data-type.h
    -rw-r--r-- 1 doragasu doragasu  6215 2011-01-15 17:40 exif-entry.h
    -rw-r--r-- 1 doragasu doragasu  1939 2011-01-15 17:40 exif-format.h
    -rw-r--r-- 1 doragasu doragasu  1528 2011-01-15 17:40 exif-ifd.h
    -rw-r--r-- 1 doragasu doragasu  4279 2011-01-15 17:40 exif-loader.h
    -rw-r--r-- 1 doragasu doragasu  3390 2011-01-15 17:40 exif-log.h
    -rw-r--r-- 1 doragasu doragasu  2584 2011-01-15 17:40 exif-mem.h
    -rw-r--r-- 1 doragasu doragasu  4256 2011-01-15 17:40 exif-mnote-data.h
    -rw-r--r-- 1 doragasu doragasu 10323 2011-01-15 17:40 exif-tag.h
    -rw-r--r-- 1 doragasu doragasu  5930 2011-01-15 17:40 exif-utils.h
    -rw-r--r-- 1 doragasu doragasu    76 2011-01-15 17:40 _stdint.h
    

    Why exif-content.h file is reported as missing?

     
  • doragasu
    doragasu
    2011-01-16

    Disabling libexim triggers the same error with expat library. Configure script searches for expat.h in the right directory but reports it can't find it!

    I'm stuck. Anyone could cross-compile this without problems?