MKV files not showing

2008-11-18
2013-05-30
  • Helge Richter
    Helge Richter
    2008-11-18

    Hi!

    I got a XStream Player (http://www.digitalrise.eu/?language=en) and it's working perfectly with avi and mpg files with Mediatomb and TVersity (Windows UPNP Server).

    But .mkv files won't show in the file list when they're on mediatomb. MKVs on TVersity work perfectly without transcoding.

    Do you have any ideas why that is so? I tried some of the settings PS3 Users use to show .mkv files but it didn't work. Won't show them either. So I set the mediatype to avi for .mkv files. That causes them to show up, but the player won't play them because of bad mediaformat.

    Any ideas what I could do? I'd really like to play back my .mkv files with mediatomb but I can't transcode them due to mediatomb running on a NAS...

    I appreciate any help! :)

     
    • Helge Richter
      Helge Richter
      2008-11-18

      Ah damn.. Wrong forum. Sorry for that.. I can't move it myself and I don't want to double-post so if a mod sees this, can you please move the topic to the "help" section? Thank you!

       
    • Eric Davis
      Eric Davis
      2008-11-19

      you should have :

      <map from="mkv" to="video/x-matroska"/>

      in mappings.   You aren't transcoding, so that alone should allow mediatomb to display it.   On the product page for that, I don't see mkv files specifically supported.  Windows will play the mkv without issue (depending on player) but there usually has to be something specific hardware wise to play mkv on other devices .. or you need a very fast processor.

      Unless I am missing something in what you are trying to do ?