Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

flac transcoding & LG TV

usverg
2013-09-28
2013-09-29
  • usverg
    usverg
    2013-09-28

    hi, i can't get working transcoding of flac files. mediatomb is running on Dlink DNS-325, LG TV is not able to play any loseless except .wav over DLNA so I tried to use transcoding feature of MT but it just doesnt work for me.
    At first here is MT info:
    root@NAS:~# mediatomb --compile-info

    MediaTomb UPnP Server version 0.12.1 - http://mediatomb.cc/

    ===============================================================================
    Copyright 2005-2010 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
    MediaTomb is free software, covered by the GNU General Public License version 2

    Compile info:

        host:                   armv5tel-unknown-linux-gnueabi
        sqlite3:                yes
        mysql:                  missing
        libjs:                  missing
        libmagic:               yes
        inotify:                yes
        libexif:                missing
        id3lib:                 disabled
        taglib:                 missing
        ffmpeg                  missing
        libmp4v2:               missing
        external transcoding:   yes
        curl:                   yes
        YouTube:                yes
        libextractor            disabled
        db-autocreate:          yes
        debug log:              yes
        protocol info extension:yes
        ffmpegthumbnailer:      missing
        lastfmlib:              missing
        data directory:         /ff1/share/mediatomb
    

    My current config.xml can be found here: http://zalil.ru/34745452 - it containts audio/x-flac MIME and transcoding section for it that uses /opt/bin/flac as external transcoder (it exists there and works from command line fine).
    But TV still cant play listed by DLNA files. It actually doesn't even try to open file cuz seems it receives list of files with unknown for it MIME - every .flac file marked with red rectangle in files list on TV. If I manually change MIME type of any .flac file in MT's Web UI to audio/wav - then TV shows it without red rectangle and and tries to play it when clicked - but this gives 'invalid file' error (obviously MT doesnt try to transcode such file cuz its not audio/x-flac anymore).
    Also I tried to find any 'low-level' tools to see what MT sends to TV. I found some references about 'Cidero Control' but their site seems doesnt exists anymore... May be sombody here has its Windows installer saved?

     
    Last edit: usverg 2013-09-28
  • usverg
    usverg
    2013-09-28

    update: seems I dont need Cidero anymore cuz found 'UPNP Inspector' tool.
    Also I managed to fix issue with setting hide-original-resource to 'yes'
    Thanks all for help ;)

     
    Last edit: usverg 2013-09-28
  • usverg
    usverg
    2013-09-29

    One more thing or may be 'feature request'. There'is such loseless format named wavpack (files with .wv extension) and its native decoder wvunpack has one strange disturbing feature that complicated a bit its use as transcoder for mediatomb. wvunpack automatically appends extension to decoded file (.wav) if its not specified in command line. So if it launched say wvunpack -y -o /tmp/decoded /music/song.wv - it creates /tmp/decoded.wav file instead. My current workaround is such a shell script:
    trap "rm $1.z; exit" SIGHUP SIGINT SIGTERM
    touch "$1"
    ln "$1" "$1.z"
    /opt/bin/wvunpack -y -o "$1.z" "$2"
    unlink "$1.z"
    So wvunpack sees there some extension and doesnt append .wav, but it would look better and work faster (its a poor ARM system with 256megs RAM) without intermediate script, and there would be no such problem at all if mediatomb created not /tmp/mt_transcode_XXXXXX files but say /tmp/mt_transcode_XXXXXX.tmp. Of course I understand that its more problem of wvunpack than MT, but I already registered on this forum :)