#65 Reporting wrong video duration

pre 0.12 SVN
closed-works-for-me
Jin
5
2010-02-12
2010-02-06
Wayne
No

Media tomb reports the wrong duration of several media files eg mediatomb reports 40min when the correct duration is 1hr 14min. All files are MPEG-TS in mpg containers (mythtv DVB recordings)

Changing DNLA clients does not effect the problem, the same information is displayed on Windows Media Player or PS3.

The same file is reported correctly using a different DNLA server (mythtv's inbuilt server).

Discussion

1 2 > >> (Page 1 of 2)
  • Jin
    Jin
    2010-02-06

    Please try executing "ffmpeg -i yourtsfile", is the duration displayed correctly there or is it the same as in MediaTomb?

    We use ffmpeg to extract the duration information, if the library returns wrong data - there's nothing we can do.

     
  • Wayne
    Wayne
    2010-02-06

    "ffmpeg -i" reports the correct duration

     
  • Wayne
    Wayne
    2010-02-06

    A bit more information, on investigation BOTH servers report the wrong duration mediatomb reports 40min whilst mythtv reports 1hr exactly. The correct duration is 1hr 14min.

    When playing back on the PS3 the mediatomb stream will stop at the 40 min mark, the mythtv stream will happily play past the 1hr mark and finish at 1hr 14 min. Using windows mediaplayer both steams will play the full duration.

     
  • Jin
    Jin
    2010-02-06

    Hmm, do you have a smaller file where the problem is reproducible, that you could share with us?

     
  • Wayne
    Wayne
    2010-02-06

    I've found the "problem" with the mythtv durations at least. The mythtv server reports the duration as the duration of the actual show that was recorded not the duration of the recording. So a 1 hour show where the recording started 5 min early and ended 10 min late will be reported as 1 hour duration even though the actual duration of the playback in 1 hr 15min.

    I'll have a look through my other recordings and see if I can find a smaller one.

     
  • Wayne
    Wayne
    2010-02-06

    I've been through about 30% of my recordins and have found numerous files with the same problem. However the problem only occurs on recordings with a duration of more than 1hr. In fact all recordings so far with a duration > 1hr exibt the same problem.

     
  • Wayne
    Wayne
    2010-02-06

    I take that last comment back, I just found a single recording that has a duration of 1hr 15min and is reported correctly.

     
  • Jin
    Jin
    2010-02-06

    Hmm, I will have a look at my files, however I did not notice such a problem (maybe because my player does not care about a duration?) So I'll compare results of ffmpeg and the tags in MediaTomb. I do not have any TS files, not sure if the problem is limited to those or not? It would still be nice if I could get a sample file from you, would make it easier to reproduce and analyze the problem.

     
  • Wayne
    Wayne
    2010-02-07

    I've just found a "small" recording. Reported duration 11min 58sec, Actual duration 18min, file size 500mb. Do you have a location that I can upload to?

     
  • Jin
    Jin
    2010-02-07

    Unfortunately not, I could only download it from somewhere...

     
1 2 > >> (Page 1 of 2)