Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Get returning empty string

Help
2012-07-12
2013-08-14
  • David Bacuvka
    David Bacuvka
    2012-07-12

    Hi, having problems after updating dll

    string buffer=MI.Get(Stream_Video, 0,_T("FrameRate"), Info_Text);
    istringstream ( buffer ) >> vTrack.fps;
    buffer=MI.Get(Stream_Video, 0,_T("FrameRate_Original"), Info_Text);
    istringstream ( buffer ) >> vTrack.fps2;
    buffer=MI.Get(Stream_Video, 0,_T("Duration"), Info_Text);
    istringstream ( buffer ) >> vTrack.duration;
    buffer=MI.Get(Stream_Video, 0,_T("FrameCount"), Info_Text);
    istringstream ( buffer ) >> vTrack.frames;
    vTrack.codec=MI.Get(Stream_Video, 0,_T("CodecID"), Info_Text);

    everything except FrameRate_Original returns empty string, how is that even possible and why it was working with older version …

    on side note can someone link me older version of dll with header files? preferably below 0.7.56

     
  • everything except FrameRate_Original returns empty string, how is that even possible and why it was working with older version .

    I changed nothing about this, recently. does the GUI display the right data for the same file?

    on side note can someone link me older version of dll with header files? preferably below 0.7.56

    https://sourceforge.net/projects/mediainfo/files/binary/libmediainfo0/

     
  • Xuch
    Xuch
    2013-08-14

    Hmmm..
    I have got same problem... There's no solving for this.

     
  • Without more details (GUI output...), you'll get no answer...