Hi all,

When I run mdp.test(), I get an error and the test will not run.  When I run numpy.test() and scipy.test() those tests are successful.  I'm running MDP (version 3.3) on a Mac using an Idle shell (Python 2.7.6).

Despite this error from mdp.test(), MDP seems to be working on my code (except a lot of Deprecation Warnings ever since I installed sklearn).

Here is the error I get when I run mdp.test()
Traceback (most recent call last):
  File "<pyshell#12>", line 1, in <module>
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/mdp/test/__init__.py", line 47, in test
    return _worker(args)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/mdp/test/__init__.py", line 77, in <lambda>
    return lambda args: subtest(script, args)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/mdp/test/__init__.py", line 54, in subtest
    stderr = sys.stderr)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 701, in __init__
    errread, errwrite), to_close = self._get_handles(stdin, stdout, stderr)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 1127, in _get_handles
    c2pwrite = stdout.fileno()
UnsupportedOperation: fileno

And in case it helps, here is my mdp.config
python: 2.7.6.final.0
             mdp: 3.3
 parallel python: NOT AVAILABLE: No module named pp
          shogun: NOT AVAILABLE: No module named shogun
          libsvm: NOT AVAILABLE: No module named svm
          joblib: NOT AVAILABLE: No module named joblib
         sklearn: 0.14
            numx: scipy 0.13.3
          symeig: scipy.linalg.eigh