#76 ?room() instead of room()

closed
nobody
None
5
2002-07-02
2002-06-29
Barton Willis
No

Maxima documents a room function, but one must call it as ?room().
Further, contrary to the the documentation ?room() and ?room(false)
give the same information (at least it does under gcl).

Change the documentation to something like

- Function: ?ROOM ( )
types out a description of the state of storage and stack
management in Maxima. This simply utilizes the Lisp ROOM
function.

Discussion

  • Raymond Toy
    Raymond Toy
    2002-07-01

    Logged In: YES
    user_id=28849

    Would you prefer room() instead of ?room()? Adding room()
    is straightforward.

    Also, room(false), room(), and room(true) produce different
    results on CMUCL, so I suspect gcl doesn't have any extra
    info at all.

     
  • Raymond Toy
    Raymond Toy
    2002-07-01

    Logged In: YES
    user_id=28849

    Would you prefer room() instead of ?room()? Adding room()
    is straightforward.

    Also, room(false), room(), and room(true) produce different
    results on CMUCL, so I suspect gcl doesn't have any extra
    info at all.

     
  • Logged In: YES
    user_id=366498

    Indeed (room), (room nil) and (room t) all give the same
    imformation. So this is GCL feature.

    Personally I prefer to rename ?room() to room().

     
  • Raymond Toy
    Raymond Toy
    2002-07-02

    Logged In: YES
    user_id=28849

    Added the ROOM function.

     
  • Raymond Toy
    Raymond Toy
    2002-07-02

    • status: open --> closed