#2304 plot2d ok in 5.24, not ok in 5.25

None
wont-fix
nobody
5
2014-08-14
2011-11-18
Anto
No

The following plot (either using plot2d or wxplot2d) worked fine in Maxima 5.24, no longer in 5.25

plot2d(
[discrete,
[0,1,2,3,4],
[0.0,-0.0794262121785545,0.103264657819926,0.104213428899564,0.10543553853034]
]
);

Discussion

  • Raymond Toy
    Raymond Toy
    2011-11-18

    In what way does it not work? It draws a nice line graph for me with maxima 5.25post.

    Marking as pending/worksforme.

     
  • Raymond Toy
    Raymond Toy
    2011-11-18

    • status: open --> pending
     
  • Anto
    Anto
    2011-11-18

    By me it remains stuck, with the message the "Maxima is computing" (Maxima est en train de calculer", in French). The gnuplot graph is not displayed. And the same holds when I use wxplot2d.
    I am running this on XP Professional, in the office.
    However, on a different computer (the one in the kictchen), under Vista, it works as expected.
    What kind of "library" is Maxima accessing?

     
  • Raymond Toy
    Raymond Toy
    2011-11-18

    Hmm. I don't use maxima on Windows. Plotting is normally done using gnuplot. But I don't really know what happens on windows.

    Changing status to open/none. (Isn't that supposed to happen automatically when the OP updates the bug?)

     
  • Raymond Toy
    Raymond Toy
    2011-11-18

    • status: pending --> open
     
  • Robert Dodier
    Robert Dodier
    2013-10-30

    • status: open --> wont-fix
    • Group: --> None
     
  • Robert Dodier
    Robert Dodier
    2013-10-30

    I'm closing this report as "wont-fix" since it hasn't been reproduced, and we don't have any additional info. I don't doubt that the problem exists, it's just that there is no useful action we can take at this point.