#1889 unwanted leading whitespaces in output

closed
nobody
5
2010-02-01
2010-01-31
Sergei
No

Here is a screen session which illustrates the problem:

"
(%i3) trigexpand(sin(a - b));
(%o3) sin(a) cos(b) - cos(a) sin(b)
(%i4) grind(trigexpand(sin(a - b)));

sin(a)*cos(b)-cos(a)*sin(b)$
(%o4) done
(%i5) linel: 200;
(%o5) 200
(%i6) trigexpand(sin(a - b));
(%o6) sin(a) cos(b) - cos(a) sin(b)
"

- as one can see, without 'grind' there are whitespaces before useful 'maxima' output, furthermore, increasing 'linel' increases number of whitespaces.

I do not understand why whitespaces are output in the first place.
I do not understand why increasing 'linel' increases number of the whitespaces.
I couldn't find a way to get rid of the whitespaces except for using 'grind' - maybe I wasn't looking thoroughly enough. If there is other than 'grind' way of customizing console output, it should be clearly described in the documentation very beginning, somewhere in the introduction.

it's a drag to use 'grind' with every command I enter.

'maxima' and LISP versions:

"
Maxima 5.20.1 http://maxima.sourceforge.net
using Lisp SBCL 1.0.34
".

Discussion

  • Sergei
    Sergei
    2010-01-31

    Alas, SF bug tracking system eats the whitespaces in question; just repeating the commands should illustrate my point.

     
  • Dieter Kaiser
    Dieter Kaiser
    2010-01-31

    It is the expected behaviour of Maxima to center the output in 2D-display. That is the reason for the observed effect of linel on the output.

    In linear display (enter display2d:false) the output is aligned on the left side. Perhaps that is a modus you would like more.

    Closing this bug report as invalid.
    Dieter Kaiser

     
  • Dieter Kaiser
    Dieter Kaiser
    2010-01-31

    • status: open --> closed
     
  • Raymond Toy
    Raymond Toy
    2010-02-01

    Reopening bug and copying the comment from bug 2943452 here:

    I do not know how to reopen a bug, so I'm opening a new one which is meant
    to be bug #2943403 reopened.

    Regarding "It is the expected behaviour of Maxima to center the output in
    2D-display.
    That is the reason for the observed effect of linel on the output." - no
    other interactive program I've dealt so far in more than 30 years of my
    involvement with computers behaves the way 'maxima' does.

    So, I do not think such a behavior can be called "expected" by most of the
    users. As I wrote, 'maxima' documentation should prominently explain _in_
    _the_ _very_ _beginning_ how to get rid of such behavior.

     
  • Raymond Toy
    Raymond Toy
    2010-02-01

    • status: closed --> open
     
  • Raymond Toy
    Raymond Toy
    2010-02-01

    Parts of maxima are more than 30 years old, you are too young. :-)

    Every math text book I have ever used has formulas centered on the line, which is what maxima does.

    If this is annoying, you can use display2d:false, as Dieter says. You lose the 2D display, but you also lose the leading whitespace which seems far more annoying to you.

     
  • Robert Dodier
    Robert Dodier
    2010-02-01

    Closing this report (was marked invalid but not closed before).

    Sounds like display2d:false is called for.

     
  • Robert Dodier
    Robert Dodier
    2010-02-01

    • status: open --> closed