#1031 Plotting constant functions works only when they're 2^z

closed
nobody
5
2006-12-19
2006-11-29
Anonymous
No

Hi Maxima-team,

I have the problem that I'm unable to insert constant functions into a plot. Maxima will do calculations forever and hangs (using CPU power).

I found out that _some_ constant functions are indeed plotted but only those that have the form 2^z.

So for example you can plot y=0.5, y=1, y=2 or y=0.03125. Things don't work are y=0.4 or y=0.028

This is in all revisions I tested so far including the recent 5.10.

HTH,
Phil

Discussion

  • Raymond Toy
    Raymond Toy
    2006-11-29

    Logged In: YES
    user_id=28849
    Originator: NO

    This was caused by the adaptive plotter. This is fixed in CVS, I think. Can you try that out?

     
  • Robert Dodier
    Robert Dodier
    2006-12-04

    Logged In: YES
    user_id=501686
    Originator: NO

    Not observed in Maxima 5.10.0cvs w/ GCL, SBCL, and Clisp.

    Marking this report as pending (so it will be closed automatically in 2 weeks, in case Phil comes back) since it seems to be fixed, and it is a duplicate of bug report 1571454: plot2d(0.99,[x,0,5]) is very slow.

     
  • Robert Dodier
    Robert Dodier
    2006-12-04

    • status: open --> pending
     
    • status: pending --> closed
     
  • Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).